Package Details: linux-mainline 5.4rc4-1

Git Clone URL: https://aur.archlinux.org/linux-mainline.git (read-only)
Package Base: linux-mainline
Description: The Linux-mainline kernel and modules
Upstream URL: https://kernel.org/
Licenses: GPL2
Submitter: miffe
Maintainer: miffe
Last Packager: miffe
Votes: 233
Popularity: 2.823409
First Submitted: 2011-07-22 06:50
Last Updated: 2019-10-21 09:05

Latest Comments

1 2 3 4 5 6 ... Next › Last »

miffe commented on 2019-10-01 18:03

@C0rn3j: The problem is that that 5.4.rc1 > 5.4. Same problem with 5.4_rc1. Only thing that would work is 5.4-rc1, but that's not an allowed pkgver.

C0rn3j commented on 2019-09-30 20:08

I assume you looked at how the 'linux' package is built - https://git.archlinux.org/svntogit/packages.git/tree/trunk/PKGBUILD?h=packages/linux

Oh well, that's a shame, thanks for trying!

miffe commented on 2019-09-30 19:47

@C0rn3j: Sorry, but i couldn't figure out a way to do it.

Shadowigor commented on 2019-08-21 09:55

I just tried to compile this kernel and I'm getting the following error:

*** WARNING *** there are active plugins, do not report this as a bug unless you can reproduce it without enabling any plugins.
Event                            | Plugins
PLUGIN_FINISH_TYPE               | structleak_plugin
PLUGIN_ATTRIBUTES                | structleak_plugin
In file included from ./include/linux/tcp.h:20,
                 from ./include/linux/ipv6.h:87,
                 from ./include/net/ipv6.h:12,
                 from ./include/net/inetpeer.h:16,
                 from ./include/net/route.h:24,
                 from ./include/net/ip.h:28,
                 from ./include/net/busy_poll.h:18,
                 from drivers/net/ethernet/sfc/falcon/net_driver.h:29,
                 from drivers/net/ethernet/sfc/falcon/ethtool.c:12:
./include/net/inet_connection_sock.h: In function ‘inet_csk_listen_poll’:
./include/net/inet_connection_sock.h:299:4: internal compiler error: 
Segmentation fault
  299 |    (EPOLLIN | EPOLLRDNORM) : 0;
      |    ^

I didn't change anything in the package, so I'm not sure what this plugin warning means and how I would disable it. A compiler segfault sounds like a compiler bug, is this the case or is there something wrong with the package? I tried to compile it twice so far and could reproduce it. I'm using the current GCC 9.1.0 for the compilation.

miffe commented on 2019-08-19 23:52

@C0rn3j: Can't change it now without introducing an epoch. But i'll do it for 5.4

C0rn3j commented on 2019-08-17 10:56

Would you please consider changing the pkgver naming from "5.3rc4" to either "5.3-rc4" or "5.3.rc4" to be more consistent with the default kernel naming?

uname -r vs pacman -Q:

5.2.8-arch1-1-ARCH | linux 5.2.8.arch1-1

5.3.0-rc4-mainline | linux-mainline 5.3rc4-1

Also if the pkgrel could be present in the uname string, that'd be perfect then.

I'm making a script that detects running vs installed kernel version and would appreciate to have less/no workarounds for mainline, thanks!

SibrenVasse commented on 2019-07-22 21:49

@marcin19883 https://www.tldp.org/HOWTO/SCSI-2.4-HOWTO/kconfig.html

marcin19883 commented on 2019-07-22 21:21

CONFIG_SND_SOC_INTEL_BYT_CHT_CX2072X_MACH is not set

how to turn on?

SibrenVasse commented on 2019-07-22 20:26

The upstream default is:

# CONFIG_SND_SOC_INTEL_BYT_CHT_CX2072X_MACH is not set

You'd have to enable this.

https://cateee.net/lkddb/web-lkddb/SND_SOC_INTEL_BYT_CHT_CX2072X_MACH.html

marcin19883 commented on 2019-07-22 20:06

Kernel 5.3 rc1. Module snd-soc-sst-byt-cht-cx2072x not available. Sound not working on Arch. On ubuntu it works.