Package Details: linux-lts414-docs 4.14.230-1

Git Clone URL: https://aur.archlinux.org/linux-lts414.git (read-only, click to copy)
Package Base: linux-lts414
Description: Kernel hackers manual - HTML documentation that comes with the Linux-lts414 kernel
Upstream URL: https://www.kernel.org/
Licenses: GPL2
Submitter: severach
Maintainer: severach
Last Packager: severach
Votes: 9
Popularity: 0.000322
First Submitted: 2019-01-01 20:55
Last Updated: 2021-04-11 22:17

Latest Comments

1 2 3 Next › Last »

severach commented on 2021-02-09 22:54

Downgrade to binutils 2.35.1-1 to build.

eschwartz commented on 2021-01-03 01:11

Unless you provide the same uname -r and /lib/modules/${_kernver}/ directory (protip: you don't, this is based on _kernelname=${pkgbase#linux}) you do not provide the right interface to support modules compiled for core/linux... NOT EVEN modules compiled for core/linux 4.14.x from way back in 2018.

Now, you were warned by both me and Scimmia, which is twice the warnings you had a right to receive, but I am a gracious person... the next step is I'm going to delete this package if you do anything other than remove the provides. I am speaking with my TU hat on -- I will not listen to further arguments, and you will not get another warning.

severach commented on 2021-01-02 07:03

It's not broken so it won't be fixed. Arch is a source distro so you are wrong, provides is right. Nvidia needs a depends=(linux-headers=version). All other modules work correctly with provides. Please submit a bug report to add provides to linux-lts. What really need is two provides, provides=4.14 and provides=4.14.x for kernel version particular modules. We could also make up fake package names so modules could depend on them or the original names as desired. Same as Java.

Scimmia commented on 2021-01-02 05:12

2 updates and the provides still isn't fixed

Scimmia commented on 2020-12-11 00:39

nvidia? broadcom-wl? Every single module in the repos?

severach commented on 2020-12-11 00:22

What package has such a module? Don't reference any DKMS packages because my settings are there to support those packages, not packages with kernel modules inexplicably compiled for the latest kernel but with no source available.

Scimmia commented on 2020-12-09 13:15

Really? So if you have a module built against the 'linux' package it will work with this kernel with no changes? Because that's what you're claiming.

severach commented on 2020-12-09 07:30

You're wrong because every kernel is a drop in replacement for every other kernel.

Scimmia commented on 2020-12-08 23:37

It doesn't work that way, that's not how provides works. Saying this provides linux means that it's a drop-in, binary replacement. It's not. If your modules require 'linux', that means that they're being built against the 'linux' kernel, or they're poorly packaged.

severach commented on 2020-12-08 18:30

No, in fact the opposite is true. The repo Linux LTS (currently 5.4) needs to PROVIDE linux. I build more than a dozen kernel modules. I add provides so they work properly. Try uninstalling the latest Linux and see how many things break.