Package Details: linux-lts-tomoyo-headers 4.19.58-1

Git Clone URL: https://aur.archlinux.org/linux-lts-tomoyo.git (read-only)
Package Base: linux-lts-tomoyo
Description: Header files and scripts for building modules for Linux-lts-tomoyo kernel
Upstream URL: https://www.kernel.org/
Keywords: tomoyo
Licenses: GPL2
Provides: linux-lts-tomoyo-headers=4.19.58
Submitter: dysphoria
Maintainer: dysphoria
Last Packager: dysphoria
Votes: 3
Popularity: 0.000004
First Submitted: 2015-01-23 19:11
Last Updated: 2019-07-11 17:01

Pinned Comments

dysphoria commented on 2019-05-06 04:17

Since the new tomoyo-tools 2.6 branch lists that only kernel 5.1 and later is supported, I've added a dependency on tomoyo-tools-25 to prevent any system breakage when updating.

This shouldn't cause any problems since other than naming, tomoyo-tools-25 is identical to the current tomoyo-tools.

Latest Comments

dysphoria commented on 2019-05-06 04:17

Since the new tomoyo-tools 2.6 branch lists that only kernel 5.1 and later is supported, I've added a dependency on tomoyo-tools-25 to prevent any system breakage when updating.

This shouldn't cause any problems since other than naming, tomoyo-tools-25 is identical to the current tomoyo-tools.

badonkadong commented on 2018-05-24 07:34

Now it works mate ! thanks for doing this

dysphoria commented on 2018-05-23 22:17

I've just tested both the -tomoyo and -lts-tomoyo, and was able to successfully build both; not sure what could be causing your errors.

I've bumped both to the latest version; hopefully that'll (magically) fix it.

badonkadong commented on 2018-05-22 07:53

Hey there, i've got an updated system now, this is what i get from makepkg:

make[2]: [Makefile:46: /home/user/Downloads/linux-lts-tomoyo/src/linux-4.14/tools/objtool/objtool-in.o] Error 2 make[1]: [Makefile:62: objtool] Error 2 make: [Makefile:1633: tools/objtool] Error 2 make: Waiting for unfinished jobs.... LD arch/x86/purgatory/purgatory.ro BIN2C arch/x86/purgatory/kexec-purgatory.c ==> ERROR: A failure occurred in prepare(). Aborting...

Now, apparently the error lies in here:

pager.c: In function 'pager_preexec': pager.c:36:12: error: passing argument 2 to restrict-qualified parameter aliases with argument 4 [-Werror=restrict] select(1, &in, NULL, &in, NULL); ^~~ ~~~ CC /home/user/Downloads/linux-lts-tomoyo/src/linux-4.14/tools/objtool/run-command.o ../lib/str_error_r.c: In function 'str_error_r': ../lib/str_error_r.c:25:3: error: passing argument 1 to restrict-qualified parameter aliases with argument 5 [-Werror=restrict] snprintf(buf, buflen, "INTERNAL ERROR: strerror_r(%d, %p, %zd)=%d", errnum, buf, buflen, err); ^~~~~~~~ cc1: all warnings being treated as errors CC /home/user/Downloads/linux-lts-tomoyo/src/linux-4.14/tools/objtool/sigchain.o mv: cannot stat '/home/user/Downloads/linux-lts-tomoyo/src/linux-4.14/tools/objtool/.pager.o.tmp': No such file or directory

" all warnings being treated as errors" doesn't sound good i guess

dysphoria commented on 2017-01-22 14:43

Thanks. Should be fixed now in the 4.4.44.

badonkadong commented on 2017-01-20 17:45

Hey sorry to bother again
it apears that a patch file is missing

patch: **** Can't open patch file /home/user/.cache/pacaur/linux-lts-tomoyo/src/fix_race_condition_in_packet_set_ring.diff : No such file or directory
==> ERROR: A failure occurred in prepare().
Aborting...

dysphoria commented on 2016-08-23 12:24

That is the line in the default Arch kernel config,
the PKGBUILD replaces that line with the appropriate settings.

badonkadong commented on 2016-08-20 15:57

# CONFIG_SECURITY_TOMOYO is not set
???