Package Details: linux-gpib-dkms 4.3.4-1

Git Clone URL: https://aur.archlinux.org/linux-gpib-dkms.git (read-only, click to copy)
Package Base: linux-gpib-dkms
Description: A support package for GPIB (IEEE 488) hardware (DKMS version).
Upstream URL: http://linux-gpib.sourceforge.net/
Keywords: science
Licenses: GPL
Conflicts: linux-gpib
Provides: linux-gpib
Submitter: Foucault
Maintainer: Foucault
Last Packager: Foucault
Votes: 2
Popularity: 0.000000
First Submitted: 2016-03-14 13:31
Last Updated: 2021-02-04 15:14

Dependencies (5)

Required by (6)

Sources (3)

Latest Comments

1 2 3 Next › Last »

Foucault commented on 2021-01-19 11:05

There's no way for me to test whether it builds let alone works for ARM so unless someone can take up that part I'd rather keep it simple. You can always use --ignorearch with makepkg.

alzyx commented on 2021-01-19 10:52

thanks a lot @grimler ! I gave it a try and it compiled ok.

Then dkms install, then depmod, ... no issues

I didnt test it on the run yet, but I guess the mantainer could add aarch64 to the architectures list!

grimler commented on 2021-01-19 10:07

@alzyx It happens because aarch64 is not an architecture listed in the PKGBUILD. Generally it means that the person that created the package has not tested it for that arch, but it could also mean that it simply not works on that arch.

You can edit the PKGBUILD and add aarch64 to the arches here: https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=linux-gpib-dkms#n9 and give it a try.

alzyx commented on 2021-01-19 10:02

I'm new to Arch, so please be kind (really Manjaro in my case). I setup a RaspberryPi4 with Manjaro, and I need it to interface it with instruments via GPIB, where I work.

A collegue of mine was able to do it on a Manjaro-PC, using:

  • pamac build linux-gpib-dkms *.

But on my Rapsberry, I get back this:

  • linux-gpib-dkms is not available for 'aarch64' architecture. *

There is some solution? thanks...

grimler commented on 2020-02-11 12:34

I had to apply this patch to not receive a make error during pacman -U linux-gpib-dkms-4.3.0-2-x86_64.pkg.tar.xz:

diff -u -r ./linux-gpib-kernel-4.3.0/drivers/gpib/fmh_gpib/fmh_gpib.c ../linux-gpib-4.3.0.orig/linux-gpib-kernel-4.3.0/drivers/gpib/fmh_gpib/fmh_gpib.c
--- ./drivers/gpib/fmh_gpib/fmh_gpib.c.orig 2020-01-31 17:38:50.187303346 +0100
+++ ./drivers/gpib/fmh_gpib/fmh_gpib.c  2020-01-31 17:31:11.967860033 +0100
@@ -982,7 +982,7 @@
 }

 /* Match callback for driver_find_device */
-static int fmh_gpib_device_match(struct device *dev, void *data)
+static int fmh_gpib_device_match(struct device *dev, const void *data)
 {
    const gpib_board_config_t *config = data;


greyltc commented on 2019-01-12 12:11

Ah, thanks!

Foucault commented on 2019-01-11 18:39

Python bindings are standalone packages

https://aur.archlinux.org/packages/python-linux-gpib/ and https://aur.archlinux.org/packages/python2-linux-gpib/

greyltc commented on 2019-01-11 17:52

Hey, could you please enable the python3 bindings here? See my PKGBUILD, linux-gpib-svn for an example of how you might do that.

trincer commented on 2018-11-07 22:32

Thanks for the really quick update. (edited for style) -- This appeared.

In order to use the new version, reload all gpib modules manually.

:: Running post-transaction hooks...

(1/2) Install DKMS modules

/usr/src/linux-gpib-4.2.0/dkms.conf: line 65: unexpected EOF while looking for matching `"'

/usr/src/linux-gpib-4.2.0/dkms.conf: line 66: syntax error: unexpected end of file

/usr/src/linux-gpib-4.2.0/dkms.conf: line 65: unexpected EOF while looking for matching `"'

/usr/src/linux-gpib-4.2.0/dkms.conf: line 66: syntax error: unexpected end of file

==> dkms install linux-gpib/4.2.0 -k 4.18.16-arch1-1-ARCH

/usr/src/linux-gpib-4.2.0/dkms.conf: line 65: unexpected EOF while looking for matching `"'

/usr/src/linux-gpib-4.2.0/dkms.conf: line 66: syntax error: unexpected end of file

dkms.conf: Error! No 'DEST_MODULE_LOCATION' directive specified.

Error! Bad conf file.

File: /usr/src/linux-gpib-4.2.0/dkms.conf

does not represent a valid dkms.conf file.

(2/2) Arming ConditionNeedsUpdate...

Foucault commented on 2018-04-29 14:48

Unfortunately it is not compatible with >= 4.15. The SVN version works but there is no stable version update yet.