Package Details: linux-git-headers 5.10rc2.r81.g4ef8451b3326-1

Git Clone URL: https://aur.archlinux.org/linux-git.git (read-only, click to copy)
Package Base: linux-git
Description: Headers and scripts for building modules for the Linux (Git) kernel
Upstream URL: https://www.kernel.org
Keywords: kernel linux
Licenses: GPL2
Submitter: jonathanio
Maintainer: jonathanio
Last Packager: jonathanio
Votes: 7
Popularity: 0.030276
First Submitted: 2019-12-22 10:10
Last Updated: 2020-11-04 21:11

Pinned Comments

jonathanio commented on 2019-12-22 10:14

The last version of the linux-git package was disowned and deleted. I've restored it taken ownership, as I do make use of this package.

This package will automatically update it's version

Note: This is a -git package and the version will automatically update to the latest mainline commit when it is run, having pulled down the branch from the repository. It will normally only be updated between major versions in order to include any updated configuration for new modules and features or settings changes.

Latest Comments

1 2 3 4 5 Next › Last »

sickcodes commented on 2021-03-05 18:20

Extremely important if you use a swap file (e.g. fallocate, dd)

https://lwn.net/Articles/848265/

Do not touch 5.12-rc1, Linus says there is a bug that can overwrite data if you use a swap file.

Harvey commented on 2021-02-01 12:35

@mxfm: I can confirm that the linux-mainline package works for me. You seem to be right. Thanks for the hint!

mxfm commented on 2021-02-01 06:10

@Harey then there is a bug in kernel code (if generated package is unbootable for several rc versions) or there is some rare issue with the package (if you cannot boot neither 5.09 or 5.10). Perhaps the -git package does not include some necessary driver for your machine, which is included in core archlinux package (you can try to copy 'config' file from archlinux trunk).

For the reasons already mentioned, I switched to the mainline AUR package which provides rc versions each Monday. These rc versions are likely to be more stable that random git versions, but bugs are still possible. I can say that the mainline pakage is bootable at least for me for the last 5-7 rc versions, including current rc5.

Harvey commented on 2021-01-31 13:34

@mxfm: Yes, I know that as it has been mentioned often before. Believe me, I have been patient and I retested for a lot of times but never had success with any incarnation of 5.11. And from what ArthurBorsboom said, there is at least some workaround that implies that maybe also the package is at fault. There might be some config changes from 5.10 to 5.11 causing this issue. Only an uneducated guess, of course ;)

mxfm commented on 2021-01-30 13:28

@Harey it is git source code and it can be broken at any time. When I used this package I experienced at least 2-3 times consistent boot failures. To solve this is issue you can wait when the issue in source code will be fixed.

jonathanio commented on 2021-01-29 08:43

I'll try and take a look at this on the weekend. I've been moving house recently and not had much free time.

ArthurBorsboom commented on 2021-01-29 08:42

I had the same problem. As a workaround I replaced the kernel config in the package with the kernel config from my installed Arch system (/proc/config.gz).

Harvey commented on 2021-01-28 17:58

No matter what I do I can't get this to work. The package compiles and installs correctly but when loading initial ramdisk it hangs there forever. Did I oversee something? This used to work on my machine when I last tried it with kernel 5.10...

IOAOI commented on 2021-01-07 02:31

If you follow these instructions: https://wiki.archlinux.org/index.php/Bisecting_bugs_with_Git and do makepkg -o then checkout an older version somehow and run makepkg -e there are errors as "version" is now wrong. In _package ():

  cd $_srcname
  make -s kernelrelease > version   <--- added
  local kernver="$(<version)"

this avoided those errors. (Only tested that on one build mind you.) Presumably the wiki info predates this commit about a year ago: https://aur.archlinux.org/cgit/aur.git/commit/PKGBUILD?h=linux-git&id=e7e35802193bf14e094a5c12e7748c600ce9ea80

ArthurBorsboom commented on 2020-12-09 12:57

Kernel 5.10.0-rc7 can be build if you revert 1 commit; this is build issue upstream (see linux-next-git package comments).

git revert 3351b16af494 --no-edit

After the build of 5.10.0-rc7 and rebooting my system (AMD Renoir 4800U), it hangs with a black screen.

To fix this I had to use my running kernel config, which I found in /proc/config.gz

Could it be that the config in this package is not in line with the normal 'linux' package (outdated?) and needs fixing?