Package Details: linphone-desktop 4.2.3-1

Git Clone URL: https://aur.archlinux.org/linphone-desktop.git (read-only, click to copy)
Package Base: linphone-desktop
Description: A free VoIP and video softphone based on the SIP protocol
Upstream URL: http://linphone.org
Licenses: GPL
Submitter: Megver83
Maintainer: Megver83
Last Packager: Megver83
Votes: 1
Popularity: 0.36
First Submitted: 2020-07-23 05:07
Last Updated: 2020-10-23 20:16

Pinned Comments

Megver83 commented on 2020-08-02 22:38

FYI, I maintain binary builds in Parabola GNU/Linux-libre, you can get it from here -> https://www.parabola.nu/packages/pcr/x86_64/linphone-desktop/ (it's also for i686)

To install it, just run:

$ pacman -U https://www.parabola.nu/packages/pcr/x86_64/linphone-desktop/download/

All its dependencies are built in Parabola too, and you can get them from there, however you may want this only if linphone-desktop is causing some trouble at build.

If you're having trouble with the signing key, you may want to download and then install the local package. For this, do the following:

$ wget --content-disposition 'https://www.parabola.nu/packages/pcr/x86_64/linphone-desktop/download/'
$ pacman -U linphone-desktop-4.2.2-1-x86_64.pkg.tar.xz

This example is for Linphone 4.2.2. Change the version accordingly

Latest Comments

Megver83 commented on 2020-09-07 13:16

@DAC324, I edited my fixed comment with the solution to your problem. This version works, it's likely that your compiler may have messed up with something. Check your makeflags.

DAC324 commented on 2020-09-07 13:04

@Megver83:

$ pacman -U https://www.parabola.nu/packages/pcr/x86_64/linphone-desktop/download/
At first, at least on my system, pacman requires root privileges for this operation. Hence,the command line should look like
$ sudo pacman -U https://www.parabola.nu/packages/pcr/x86_64/linphone-desktop/download/

Nevertheless, your package could not be installed:

Error: '/var/cache/pacman/pkg/linphone-desktop-4.2.2-1-x86_64.pkg.tar.xz': Invalid or damaged Package (PGP-Signature)

I had confirmed importing of the PGP key but to no avail. What am I supposed to do?

DAC324 commented on 2020-09-07 12:49

This version does not run:

[14:46:45:906][0x559781dac620][Info]app/App.cpp:778: "Open Linphone app."
[14:46:45:906][0x559781dac620][Info]app/App.cpp:225: "Creating subwindow: qrc:/ui/views/App/Calls/CallsWindow.qml."
[14:46:45:997][0x559781dac620][Info]app/App.cpp:232: "Subwindow status: 1."
[14:46:46:001][0x559781dac620][Warning]qrc:/ui/views/App/Calls/CallsWindow.qml:241: qrc:/ui/views/App/Calls/CallsWindow.qml:241:3: QML Connections: Implicitly defined onFoo properties in Connections are deprecated. Use this syntax instead: function onFoo(<arguments>) { ... }
[14:46:46:001][0x559781dac620][Warning]qrc:/ui/modules/Linphone/Calls/Calls.qml:32: qrc:/ui/modules/Linphone/Calls/Calls.qml:32:3: QML Connections: Implicitly defined onFoo properties in Connections are deprecated. Use this syntax instead: function onFoo(<arguments>) { ... }
[14:46:46:006][0x559781dac620][Info]app/App.cpp:225: "Creating subwindow: qrc:/ui/views/App/Settings/SettingsWindow.qml."
[14:46:46:048][0x559781dac620][Info]app/App.cpp:232: "Subwindow status: 1."
[14:46:46:164][0x559781dac620][Warning]qrc:/ui/views/App/Settings/SettingsAdvanced.qml:91: qrc:/ui/views/App/Settings/SettingsAdvanced.qml:91:7: QML Connections: Implicitly defined onFoo properties in Connections are deprecated. Use this syntax instead: function onFoo(<arguments>) { ... }
[14:46:46:301][0x559781dac620][Warning]qrc:/ui/views/App/Settings/SettingsVideo.qml:149: qrc:/ui/views/App/Settings/SettingsVideo.qml:149:7: QML Connections: Implicitly defined onFoo properties in Connections are deprecated. Use this syntax instead: function onFoo(<arguments>) { ... }
[14:46:46:301][0x559781dac620][Warning]qrc:/ui/views/App/Settings/SettingsVideo.qml:142: qrc:/ui/views/App/Settings/SettingsVideo.qml:142:7: QML Connections: Implicitly defined onFoo properties in Connections are deprecated. Use this syntax instead: function onFoo(<arguments>) { ... }
[14:46:46:421][0x559781dac620][Warning]qrc:/ui/views/App/Main/Assistant/AssistantHome.qml:132: qrc:/ui/views/App/Main/Assistant/AssistantHome.qml:132:5: QML Connections: Implicitly defined onFoo properties in Connections are deprecated. Use this syntax instead: function onFoo(<arguments>) { ... }
[14:46:46:696][0x559781dac620][Info]components/core/event-count-notifier/AbstractEventCountNotifier.cpp:66: "Notify event count: 0."
Segmentation fault (Core dumped)

Megver83 commented on 2020-08-03 17:08

I'll see if I can make a patch for this, anyways.

Here it is: 0003-remove-bc_compute_full_version-usage.patch

Megver83 commented on 2020-08-02 22:38

FYI, I maintain binary builds in Parabola GNU/Linux-libre, you can get it from here -> https://www.parabola.nu/packages/pcr/x86_64/linphone-desktop/ (it's also for i686)

To install it, just run:

$ pacman -U https://www.parabola.nu/packages/pcr/x86_64/linphone-desktop/download/

All its dependencies are built in Parabola too, and you can get them from there, however you may want this only if linphone-desktop is causing some trouble at build.

If you're having trouble with the signing key, you may want to download and then install the local package. For this, do the following:

$ wget --content-disposition 'https://www.parabola.nu/packages/pcr/x86_64/linphone-desktop/download/'
$ pacman -U linphone-desktop-4.2.2-1-x86_64.pkg.tar.xz

This example is for Linphone 4.2.2. Change the version accordingly

Megver83 commented on 2020-07-30 20:21

@wazlecracker you must build it in an environment without git installed, in my case I did it in a clean chroot (you can use devtools' makechrootpkg for this).

I'll see if I can make a patch for this, anyways.

wazlecracker commented on 2020-07-30 20:16

Getting the following error when trying to build:

CMake Error at /usr/share/bctoolbox/cmake/bctoolboxCMakeUtils.cmake:162 (message):
invalid git describe version: ''
Call Stack (most recent call first):
linphone-app/build/CMakeLists.txt:49 (bc_compute_full_version)