Package Details: linode-cli 5.11.0-1

Git Clone URL: https://aur.archlinux.org/linode-cli.git (read-only, click to copy)
Package Base: linode-cli
Description: Linode API wrapper
Upstream URL: https://github.com/linode/linode-cli
Keywords: cli python
Licenses: BSD
Replaces: linode-cli-dev
Submitter: slithery
Maintainer: morgenstern
Last Packager: morgenstern
Votes: 8
Popularity: 0.131922
First Submitted: 2015-08-12 20:52
Last Updated: 2021-10-18 19:54

Dependencies (6)

Required by (0)

Sources (2)

Pinned Comments

morgenstern commented on 2021-02-06 22:37

As of version 3.2.1.20201118-4, this package has been updated to the enum34 commit and patched to eliminate any Python 2 dependencies.

Latest Comments

1 2 3 Next › Last »

morgenstern commented on 2021-05-09 04:54

Fixed, thanks @nogweii.

nogweii commented on 2021-05-09 04:42

@morgenstern there is an unspecified make dependency on python-setuptools. Attempting to build this package in a clean container/chroot after the update to 5.2.0 results in a "ModuleNotFoundError: No module named 'pkg_resources'" error. That module is provided by python-setuptools, which is commonly pulled in as a dependency on one way or another, so it's not surprising it was missed. :)

morgenstern commented on 2021-02-27 23:58

@krathalan thanks, fixed.

krathalan commented on 2021-02-27 23:28

The upstream URL should be https://github.com/linode/linode-cli. Notice the Github user has changed from "linode-cli" to just "linode". Your source=() array seems to fix this but $url doesn't.

Thanks for the great PKGBUILD.

morgenstern commented on 2021-02-06 22:37

As of version 3.2.1.20201118-4, this package has been updated to the enum34 commit and patched to eliminate any Python 2 dependencies.

morgenstern commented on 2020-12-17 22:07

Right on - will probably look to modify this package in the new year so that it builds from the enum34 commit and also just builds Python 3, as this is literally the last package on my system that "requires" Python 2. :p

alex19EP commented on 2020-12-17 21:49

hay @morgenstern. glad you noticed. in fact, I created that package because I didn't succeed compiling this one, and because I just love the vcs versions and don't like python2.

morgenstern commented on 2020-12-17 21:12

Hey everyone, alex19EP has written a git version of this package that dispenses with Python 2 and also includes this commit that eliminates the need for my downstream enum34 patch.

Go check it out for a more bleeding edge experience.

nitsky commented on 2020-03-26 00:44

@alex19EP I missed that on the wiki, sorry for bothering. I had previously installed fakeroot and a few others manually. Haha.

alex19EP commented on 2020-03-25 15:09

@nitsky patch is in base-devel group so. you have to install it for building pkges from aur.