Package Details: lime 4.4.21-1

Git Clone URL: https://aur.archlinux.org/lime.git (read-only, click to copy)
Package Base: lime
Description: C++ library implementing Open Whisper System Signal protocol
Upstream URL: http://www.linphone.org/
Licenses: GPL
Submitter: thrasibule
Maintainer: thrasibule
Last Packager: thrasibule
Votes: 0
Popularity: 0.000000
First Submitted: 2020-07-26 02:31
Last Updated: 2020-12-27 21:29

Dependencies (3)

Required by (2)

Sources (1)

Latest Comments

zsolt-donca commented on 2020-12-14 12:18

This package and the related package lime-git fail to build for me:

[ 11%] Building CXX object src/CMakeFiles/lime.dir/lime.cpp.o
In file included from /usr/include/soci/soci.h:12,
                 from /home/zdonca/.cache/yay/lime-git/src/lime/src/lime_localStorage.hpp:23,
                 from /home/zdonca/.cache/yay/lime-git/src/lime/src/lime_impl.hpp:31,
                 from /home/zdonca/.cache/yay/lime-git/src/lime/src/lime.cpp:22:
/usr/include/soci/soci-platform.h:146:10: error: #error "SOCI must be configured with C++11 support when using C++11"
  146 |         #error "SOCI must be configured with C++11 support when using C++11"
      |          ^~~~~
make[2]: *** [src/CMakeFiles/lime.dir/build.make:82: src/CMakeFiles/lime.dir/lime.cpp.o] Error 1
make[1]: *** [CMakeFiles/Makefile2:134: src/CMakeFiles/lime.dir/all] Error 2
make: *** [Makefile:149: all] Error 2
==> ERROR: A failure occurred in build().
    Aborting...
error making: lime-git

Any ideas on how to fix this?

BluePeril commented on 2020-12-02 10:19

Could you please add boost as makedepends. Otherwise the package won't build in a clean environment.