Package Details: libzkgroup 0.7.2-1

Git Clone URL: https://aur.archlinux.org/libzkgroup.git (read-only, click to copy)
Package Base: libzkgroup
Description: Library for the Signal Private Group System.
Upstream URL: https://github.com/signalapp/zkgroup
Keywords: signal zkgroup
Licenses: GPL3
Submitter: AsamK
Maintainer: AsamK
Last Packager: AsamK
Votes: 2
Popularity: 0.64
First Submitted: 2020-12-15 21:33
Last Updated: 2021-05-01 20:02

Latest Comments

1 2 3 Next › Last »

syslino commented on 2021-05-02 18:56

Thanks for replying that swiftly, but I am getting the exact same message. Downloaded the new PKGBUILD and double checked the diff. No offense, but did you test that?

AsamK commented on 2021-05-01 20:03

The deploy script of libzkgroup uses functionality removed from gradle 7. I've updated the PKGBUILD to work around the issue.

syslino commented on 2021-05-01 18:26

Getting this error:

FAILURE: Build failed with an exception.

* Where:
Script '/tmp/makepkg/libzkgroup/src/zkgroup-0.7.2/deploy.gradle' line:32

* What went wrong:
Could not compile script '/tmp/makepkg/libzkgroup/src/zkgroup- 
0.7.2/deploy.gradle'.
> startup failed:
script '/tmp/makepkg/libzkgroup/src/zkgroup-0.7.2/deploy.gradle': 32: 
unable to resolve class MavenDeployment @ line 32, column 26.
         beforeDeployment { MavenDeployment deployment -> signing.signPom(deployment) }

gkmcd commented on 2021-04-03 22:50

Build fails for me. Re-installing Gradle & jdk-openjdk didn't help.

==> Starting build()...
error: no override and no default toolchain set
==> ERROR: A failure occurred in build().
    Aborting...
error making: libzkgroup

EDIT: this is a rust problem. Installed rust, which pacman advised was in conflict with rustup? Removed rustup, installed rust, build succeeded.

morganmay commented on 2021-04-03 14:35

Broken jdk seems to have been the culprit. Reinstalling jdk-openjdk did the trick. Thanks!

AsamK commented on 2021-04-03 07:26

Might be a broken jdk installation or an incompatible gradle version. The build works fine with the latest jdk-openjdk and gradle packages.

$ java -version
openjdk version "15.0.2" 2021-01-19
OpenJDK Runtime Environment (build 15.0.2+7)
OpenJDK 64-Bit Server VM (build 15.0.2+7, mixed mode)

$ gradle --version
------------------------------------------------------------
Gradle 6.8.3
------------------------------------------------------------

morganmay commented on 2021-04-03 01:39

Build failed again for me with version 0.7.2-1. This time, I tried it with both java-15-openjdk and java-16-jdk, with no success. None of the other fixes mentioned in the comments worked for me, either. Lightly-edited error log at https://pastebin.com/brdFm8fX

I don't know much about gradle, so I might be missing something obvious.

merua commented on 2021-03-23 20:57

I tried to install this (as a dependency of signal-cli but also separately) and it has shown a Rust error (which I didn't save unfortunately). I googled the issue and found out that the commands "rustup install stable" and "rustup default stable" (before installing signal-cli or this library) solved the issues for me. Was it a problem with my local configuration or is there something missing with this AUR package?

AsamK commented on 2021-02-24 22:16

upstream has fixed the issue, the build should work again now.

AsamK commented on 2021-02-24 18:07

Ok, I could reproduce it after clearing the cargo cache. The issue is that upstream has force pushed the branch, thus removing the old commit ... https://github.com/signalapp/curve25519-dalek/pull/1#issuecomment-785265272