Package Details: libxtrx-git r53.9af1c458b567-2

Git Clone URL: https://aur.archlinux.org/libxtrx-git.git (read-only)
Package Base: libxtrx-git
Description: High level API for the xtrx SDR
Upstream URL: https://github.com/xtrx-sdr/libxtrx
Keywords: sdr xtrx
Licenses: LGPL
Conflicts: libxtrx
Provides: libxtrx
Submitter: lynxis
Maintainer: lynxis
Last Packager: lynxis
Votes: 0
Popularity: 0.000000
First Submitted: 2019-04-22 18:06
Last Updated: 2019-09-10 03:20

Dependencies (7)

Required by (1)

Sources (1)

Latest Comments

lynxis commented on 2019-09-10 03:03

Thank you @lainpants.

lainpants commented on 2019-08-14 17:19

qcustomplot-qt5 has been replaced by community/qcustomplot This patch fixes the dependency:

From 449fcb791903b0759af13ddbf4f40d78ec7a529e Mon Sep 17 00:00:00 2001
From: lain <lain@hacktheinter.net>
Date: Wed, 14 Aug 2019 10:17:39 -0700
Subject: [PATCH] PKGBUILD: change dependency qcustomplot-qt5 to qcustomplot

---
 .SRCINFO | 2 +-
 PKGBUILD | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/.SRCINFO b/.SRCINFO
index de08082..f28469c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,7 +10,7 @@ pkgbase = libxtrx-git
        depends = liblms7002m-xtrx
        depends = libxtrxdsp
        depends = libxtrxll
-       depends = qcustomplot-qt5
+       depends = qcustomplot
        depends = soapysdr
        provides = libxtrx
        conflicts = libxtrx
diff --git a/PKGBUILD b/PKGBUILD
index 3a38f36..588c210 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ makedepends=('git' 'cmake')
 depends=('liblms7002m-xtrx'
          'libxtrxdsp'
          'libxtrxll'
-         'qcustomplot-qt5'
+         'qcustomplot'
          'soapysdr')
 source=("git+$url")
 md5sums=('SKIP')
-- 
2.21.0

lynxis commented on 2019-04-24 22:19

Thanks you for the dependency. Fixed!

lainpants commented on 2019-04-24 03:13

Thanks for the package! This is missing a dependency on liblms7002m-xtrx-git