Package Details: libxfce4ui-git 1:4.15.3+58+g2bece1f-1

Git Clone URL: https://aur.archlinux.org/libxfce4ui-git.git (read-only, click to copy)
Package Base: libxfce4ui-git
Description: Commonly used Xfce widgets among Xfce applications (git checkout)
Upstream URL: https://git.xfce.org/xfce/libxfce4ui/tree/README
Licenses: GPL2
Conflicts: libxfce4ui
Provides: libxfce4ui=4.15.3
Submitter: mkljczk
Maintainer: twa022
Last Packager: twa022
Votes: 2
Popularity: 0.000000
First Submitted: 2017-03-05 17:26
Last Updated: 2020-08-12 00:57

Required by (47)

Sources (1)

Latest Comments

fuan_k commented on 2020-09-15 15:38

If you try to update from before the move to gitlab, it will show:

==> ERROR: /var/yay_cache/libxfce4ui-git/libxfce4ui is not a clone of https://gitlab.xfce.org/xfce/libxfce4ui                                                                                        
    Aborting...

Removing that directory (i.e. forcing re-download) is enough to fix the problem. rm -r /var/yay_cache/libxfce4ui-git Alternatively I suppose you could simply change the remote cd /var/yay_cache/libxfce4ui-git/libxfce4ui; git remote set-url origin https://gitlab.xfce.org/xfce/libxfce4ui to avoid re-downloading everything.

On an unrelated note, --enable-maintainer-mode does seem to be necessary to compile successfully.

jose1711 commented on 2020-09-14 14:16

@SolarAquarion

thanks for the hint with --enable-maintainer-mode. W/o that building failed:

make[3]: Entering directory '/home/jose/tmp/libxfce4ui-git/src/libxfce4ui/libxfce4ui'
make[3]: *** No rule to make target 'libxfce4ui-aliasdef.c', needed by 'libxfce4ui_2_la-libxfce4ui-aliasdef.lo'.  Stop.
make[3]: Leaving directory '/home/jose/tmp/libxfce4ui-git/src/libxfce4ui/libxfce4ui'
make[2]: *** [Makefile:802: all] Error 2
make[2]: Leaving directory '/home/jose/tmp/libxfce4ui-git/src/libxfce4ui/libxfce4ui'
make[1]: *** [Makefile:534: all-recursive] Error 1
make[1]: Leaving directory '/home/jose/tmp/libxfce4ui-git/src/libxfce4ui'
make: *** [Makefile:466: all] Error 2

SolarAquarion commented on 2020-08-17 16:54

--enable-maintainer-mode needs to be added

SolarAquarion commented on 2020-08-03 22:22

'libxfce4util>=4.13.1 just put it libxfce4util-git

mirh commented on 2020-01-10 15:51

Git requires file "libxfce4util-1.0.gir"

In turn this means that the minimum required libxfce4util version is now 4.13.1

Gamma commented on 2019-08-26 12:29

pkgver is giving me "1:xfce+4.14..." instead of "1:4.14...", so my AUR helper thinks it needs to be updated every time. could you change the sed call to strip all leading non-digits?

  git describe --long --tags | sed -r "s:^${_pkgname}.::;s/^[^[:digit:]]*//;s/-/+/g"

killermoehre commented on 2017-07-23 20:11

So, I talked with the guys in #xfce-dev and got a fix:
split up the ./autogen.sh command with many arguments in

NOCONFIGURE=1 ./autogen.sh
./configure \
--enable-maintainer-mode \
--all-the-other-options

According to ninetls from #xfce-dev the culprit is xdg-autogen in combination with autogen.sh

killermoehre commented on 2017-07-21 16:12

Hi,

would you mind to change the vendor info from »Arch Linux« to »archlinux« (also stated in /etc/os-release). Else it doesn't build.