Package Details: libxfce4ui-devel 4.15.8-1

Git Clone URL: https://aur.archlinux.org/libxfce4ui-devel.git (read-only, click to copy)
Package Base: libxfce4ui-devel
Description: Commonly used Xfce widgets among Xfce applications (Development version)
Upstream URL: https://gitlab.xfce.org/xfce/libxfce4ui/-/blob/master/README
Licenses: GPL2
Groups: xfce4-devel
Conflicts: libxfce4ui
Provides: libxfce4ui=4.15.8
Submitter: twa022
Maintainer: twa022
Last Packager: twa022
Votes: 13
Popularity: 0.000000
First Submitted: 2013-10-27 19:35
Last Updated: 2020-12-17 02:10

Required by (49)

Sources (1)

Pinned Comments

twa022 commented on 2020-12-26 13:28

Don't flag out of date. This follows development snapshots. Will update once packages in the 4.17 series are published (use the stable packages in extra/community until then).

Latest Comments

1 2 3 Next › Last »

twa022 commented on 2020-12-26 13:28

Don't flag out of date. This follows development snapshots. Will update once packages in the 4.17 series are published (use the stable packages in extra/community until then).

jonathon commented on 2020-08-25 13:55

@twa022, cool, thank you!

On another note, there's a bug in 4.15.3 which prevents keyboard shortcuts from being edited [1]. There's a small patch available [2].

twa022 commented on 2020-08-24 23:51

@jonathon: libxfce4ui as of now only requires libxfce4util 4.12.0 (https://git.xfce.org/xfce/libxfce4ui/tree/configure.ac.in). I'll add the versioned dependency on xfce4-{panel,appfinder}-devel

jonathon commented on 2020-08-22 16:08

Should the dep on libxfce4util have a version dependency ('libxfce4util>=4.15.2')? It would fix build failures on xfce4-panel-devel and xfce4-appfinder-devel.

xoan commented on 2020-06-25 20:45

xfce4-dev-tools is required when maintainer-mode is enabled:

https://gitlab.xfce.org/xfce/libxfce4ui/-/blob/master/xfce4-about/Makefile.am#L55

  GEN about-dialog-ui.h
/bin/sh: xdt-csource: command not found
make[2]: *** [Makefile:888: about-dialog-ui.h] Error 127

accensi commented on 2019-12-16 16:18

Error making pkg: make[3]: *** No rule to make target 'libxfce4ui-2.deps', needed by 'libxfce4ui-2.vapi'. Stop.

enihcam commented on 2019-07-06 03:02

Is it possible to add '--disable-gtk2' into build?

graysky commented on 2019-05-27 17:12

@twa022 - You gotta add xfce4-dev-tools as a makedeps as @xdavidwu said or else the build fails.

xdavidwu commented on 2019-05-19 03:21

missing makedepends xfce4-dev-tools for xdt-csource

Making all in xfce4-about
  GEN      about-dialog-ui.h
/bin/sh: xdt-csource: command not found
make[2]: *** [Makefile:868: about-dialog-ui.h] Error 127
make[1]: *** [Makefile:542: all-recursive] Error 1
make: *** [Makefile:474: all] Error 2

Skunnyk commented on 2018-09-11 11:05

@jackrandom yes 4.13.4 is broken with --enable-maintainer-mode switch. For now you can remove the switch from the pkgbuild.