Package Details: libx11-threadsafe 1.6.9-3

Git Clone URL: https://aur.archlinux.org/libx11-threadsafe.git (read-only, click to copy)
Package Base: libx11-threadsafe
Description: X11 client-side library - threadsafe patches by Jacek Caban
Upstream URL: https://xorg.freedesktop.org/
Licenses: custom:XFREE86
Conflicts: libx11=1.6.9
Provides: libx11=1.6.9
Submitter: Cebtenzzre
Maintainer: Cebtenzzre
Last Packager: Cebtenzzre
Votes: 0
Popularity: 0.000000
First Submitted: 2018-12-04 22:54
Last Updated: 2020-03-15 20:52

Dependencies (4)

Required by (935)

Sources (3)

Latest Comments

lash commented on 2020-03-16 06:06

yeah libx11 builds fine.

Cebtenzzre commented on 2020-03-15 21:06

@lash Does the libx11 Arch package build successfully for you? The PKGBUILDs are nearly identical, save for the patch that this one applies.

I just updated the depends and makedepends to match the current Arch package at pkgrel=6, but that shouldn't affect building.

lash commented on 2020-03-15 19:09

Build fails for me:

checking keysym definitions... ./configure: line 17640: --variable=includedir: command not found
configure: error: /X11 doesn't exist or isn't a directory

MightyUnderTaker commented on 2019-12-21 13:28

Remove dependencies on kbproto (xorgproto-git, xorgproto) xproto (xorgproto-git, xorgproto) inputproto (xorgproto-git) (make) maybe? They got removed from the new version of xorgproto and libx11 doesn't require them too.