Package Details: libvirt-git 7.0.0.r36.gb5f15b9db1-1

Git Clone URL: https://aur.archlinux.org/libvirt-git.git (read-only, click to copy)
Package Base: libvirt-git
Description: API for controlling virtualization engines (openvz,kvm,qemu,virtualbox,xen,etc)
Upstream URL: http://libvirt.org/
Keywords: git library management virtualization
Licenses: GPL3, LGPL
Conflicts: libvirt
Provides: libvirt
Submitter: xtfxme
Maintainer: sirspudd
Last Packager: sirspudd
Votes: 10
Popularity: 0.000083
First Submitted: 2009-12-06 07:37
Last Updated: 2021-01-19 02:11

Dependencies (38)

Required by (72)

Sources (4)

Latest Comments

« First ‹ Previous ... 3 4 5 6 7 8 9 10 Next › Last »

gabx commented on 2014-02-15 23:32

Can not build :
mv: cannot stat ‘/developement/aur/libvirt-git/pkg/libvirt-git/lib/*’: No such file or directory
==> ERROR: A failure occurred in package().

teekay commented on 2014-02-13 11:34

Please use
NOCONFIGURE=1 ./autogen.sh
so configure is run only once.

Also the "mv $pkgdir/lib .." line is not needed anymore (actually, package() fails now as they moved that /lib dir to /usr/lib upstream it seems)

teekay commented on 2013-11-08 15:25

Could you please change

--libexec=/usr/lib/"$pkgname"

to

--libexec=/usr/lib/"${pkgname/-git/}"

as this breaks LXC domains which have /usr/lib/libvirt/libvirt_lxc configured as hypervisor (like, when moving from libvirt to libvirt-git and vice versa).

onny commented on 2013-08-24 16:54

@ironicbadger: I can't confirm this yet. Tried to compile libvirt-git in a clean chroot-environement but it still fails with all the docbook generation.

ironicbadger commented on 2013-08-17 20:13

docbook-xml-dtd should be added to the deps... it compiled fine once this was added.

ironicbadger commented on 2013-08-16 23:04

oh and, my /etc/xml/catalog file is empty.

ironicbadger commented on 2013-08-16 23:03

I have installed xhtml-docs and docbook-xml as per the suggestions. Won't compile for me. x64.

A much large log is here. http://pastebin.com/1Dy8NjLR

make[3]: Leaving directory `/tmp/yaourt-tmp-alex/aur-libvirt-git/src/libvirt/docs'
make[2]: *** [install-recursive] Error 1
make[2]: Leaving directory `/tmp/yaourt-tmp-alex/aur-libvirt-git/src/libvirt/docs'
make[1]: *** [install] Error 2
make[1]: Leaving directory `/tmp/yaourt-tmp-alex/aur-libvirt-git/src/libvirt/docs'
make: *** [install-recursive] Error 1
==> ERROR: A failure occurred in package().
Aborting...
==> ERROR: Makepkg was unable to build libvirt-git.
==> Restart building libvirt-git ? [y/N]

onny commented on 2013-08-10 18:39

@mjevans: libvirt-git compiles fine on my system, even without docbook-xml. Can you be please more specific?

Unfortunately, it won't compile with makechrootpkg in a 32bit environement anymore. Don't know how to fix this yet.

onny commented on 2013-06-20 15:38

@Chetyre: Try again. The only thing which fails in my makechrootpkg environement could be the xhtml-docs packet but I'll fix this soon.

Anonymous comment on 2013-04-19 00:43

I needed to install libxslt before it would proceed, but it still failed.

make[3]: *** [libvirtmod_la-libvirt-override.lo] Error 1
make[3]: Leaving directory `/tmp/yaourt-tmp-host/aur-libvirt-git/src/libvirt-build/python'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/tmp/yaourt-tmp-host/aur-libvirt-git/src/libvirt-build/python'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/yaourt-tmp-host/aur-libvirt-git/src/libvirt-build'
make: *** [all] Error 2