Package Details: libtifiles-git 1.18.r41.g7be38a45-1

Git Clone URL: https://aur.archlinux.org/tilibs-git.git (read-only, click to copy)
Package Base: tilibs-git
Description: Various TI libs required for TILP
Upstream URL: http://lpg.ticalc.org/prj_tilp/
Licenses: GPL2
Conflicts: libtifiles
Provides: libtifiles
Submitter: aviallon
Maintainer: aviallon
Last Packager: aviallon
Votes: 0
Popularity: 0.000000
First Submitted: 2020-06-05 23:33
Last Updated: 2020-06-05 23:33

Latest Comments

SMF67 commented on 2020-09-25 03:55

I am experiencing the exact same issue, and have not found a workaround.

parkerlreed commented on 2020-06-08 21:14

Trying to install just libticables from the tilibs-git metapackage errors out because libticables isnt installed (Full log relating to the previous comment)

http://ix.io/2oFf

parkerlreed commented on 2020-06-08 21:10

How is this supposed to work? Some of the libs within the package depend on libs from this same package.

checking for CFPreferencesCopyAppValue... no
checking for CFLocaleCopyCurrent... no
checking for GNU gettext in libc... yes
checking whether to use NLS... yes
checking where the gettext function comes from... libc
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for GLIB... yes
checking for TICABLES... no
configure: error: Package requirements (ticables2 >= 1.3.5) were not met:

Package 'ticables2', required by 'virtual:world', not found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables TICABLES_CFLAGS
and TICABLES_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
==> ERROR: A failure occurred in build().
    Aborting...
Error making: tilibs-git (libticalcs-git)