Package Details: libsub 1.4.5-1

Git Clone URL: https://aur.archlinux.org/libsub.git (read-only)
Package Base: libsub
Description: a small C++ library to read and write subtitles in a few different formats (currently STL, SubRip and DCP)
Upstream URL: http://carlh.net/libsub
Licenses: GPL
Conflicts: libsub
Provides: libsub
Submitter: markusk
Maintainer: markusk
Last Packager: markusk
Votes: 3
Popularity: 0.000000
First Submitted: 2015-09-14 18:49
Last Updated: 2019-04-29 14:07

Latest Comments

markusk commented on 2019-03-13 15:08

As 2.14.0 is nearly there i'm switching my stable (aka none "-git") packages to the beta "tree". The beta tree is in string freeze at the moment. Please let me know if you have trouble with these new packages. The following aur pkgs will get updates today libsub,libdcp,libcxml and dcpmatic.

Info from upstream. "The sixth beta version 2.13.129 is now uploading. This fixes another crash when using PNG subtitles. All testing and bug reports welcome!"

copecu commented on 2019-02-10 07:20

@markusk:

Thank you for the feedback.

Removing packages and recompiling worked.

$ yaourt --remove dcpomatic libasdcp-cth libdcp libcxml libsub

(dcpomatic-2.12.15-1 libasdcp-cth-0.1.5-1 libcxml-0.15.5-1 libdcp-1.5.6-1 libsub-1.3.5-1)

$ yaourt --sync --refresh --aur dcpomatic

==> dependencias de dcpomatic: - pangomm>=1.4 (ya instalado) - ffmpeg>=4.0.2 (ya instalado) - glib2 (ya instalado) - imagemagick (ya instalado) - libssh (ya instalado) - wxgtk2>=3.0.1 (ya instalado) - libquickmail>=0.1.22 (ya instalado) - libzip (ya instalado) - xz (ya instalado) - libsndfile (ya instalado) - libsamplerate (ya instalado) - pangomm (ya instalado) - rtaudio (ya instalado) - x264 (ya instalado) - python2 (ya instalado) [makedepend] - boost>=1.66.0 (ya instalado) [makedepend] - libsub>=1.3.6 (compilando desde el AUR) - libcxml>=0.15.5 (compilando desde el AUR) - libdcp>=1.5.7 (compilando desde el AUR)

markusk commented on 2019-02-09 23:33

@copecu:

on my current Arch system it compiles... so let's see if we can get it to work for you too ...

a) make sure that you remove all the dcpomatic "libs" even if these have not version bumped. There might be dep-libs (most of the cases it's "boost") that changed in between. Do at least "yay -R dcpomatic libasdcp-cth libdcp libcxml libsub". Instead of yay uses whatever pac-aur-wrapper you use. Also for the crazy cases that never should happen make sure that you clear ccache (if you use it) "ccache -C"

b) if it still does not work please email the config.log file that is created during the makepkg process (-> mk@filmkreis.tu-darmstadt.de) you can also include a STDERR & STDOUT pipe like you did below but please as a txt file and if possible with English and not in Spanish(?) (-> export LANGUAGE=en_US.UTF-8 )

copecu commented on 2019-02-09 09:23

Fails to compile on Manjaro.

OS: Manjaro 18.0.2 Illyria Kernel: x86_64 Linux 4.19.16-1-MANJARO Uptime: 22m Packages: 1599 Shell: bash Resolution: 3286x1080 DE: KDE 5.54.0 / Plasma 5.14.5 WM: KWin WM Theme: Breeze High Contrast GTK Theme: Breath [GTK2/3] Icon Theme: Papirus-Dark Font: Noto Sans Regular CPU: Intel Pentium 3558U @ 2x 1.7GHz [39.0°C] GPU: Mesa DRI Intel(R) Haswell Mobile RAM: 4703MiB / 11928MiB

libsub 1.3.6-2 (2019-02-03 23:23) (Paquete sin soporte: ¡podría ser peligroso!) ==> ¿Quiere editar PKGBUILD? [S/n] («A» para anular) ==> ------------------------------------------------ ==> n

==> dependencias de libsub: - openssl (ya instalado) - libxml++2.6 (ya instalado) - xmlsec (ya instalado) - libdcp>=1.5.2 (ya instalado) - libcxml>=0.15.5 (ya instalado) - libsigc++>=2.0 (ya instalado) - boost-libs>=1.66.0 (ya instalado) - libasdcp-cth>=0.1.3 (ya instalado) - python2 (ya instalado) [makedepend] - boost>=1.66.0 (ya instalado) [makedepend]

==> conflictos de libsub: - libsub-1.3.5-1

==> ¿Continuar compilando libsub? [S/n] ==> -----------------------------------

(...)

[40/40] Linking build/test/tests /usr/bin/ld: warning: libboost_filesystem.so.1.68.0, needed by /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.1/../../../../lib/libdcp-1.0.so, not found (try using -rpath or -rpath-link) /usr/bin/ld: warning: libboost_system.so.1.68.0, needed by /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.1/../../../../lib/libdcp-1.0.so, not found (try using -rpath or -rpath-link) /usr/bin/ld: warning: libboost_date_time.so.1.68.0, needed by /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.1/../../../../lib/libdcp-1.0.so, not found (try using -rpath or -rpath-link) /usr/bin/ld: /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.1/../../../../lib/libdcp-1.0.so: referencia a `boost::system::detail::generic_category_ncx()' sin definir collect2: error: ld devolvió el estado de salida 1

/usr/bin/ld: warning: libboost_filesystem.so.1.68.0, needed by /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.1/../../../../lib/libdcp-1.0.so, not found (try using -rpath or -rpath-link) /usr/bin/ld: warning: libboost_system.so.1.68.0, needed by /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.1/../../../../lib/libdcp-1.0.so, not found (try using -rpath or -rpath-link) /usr/bin/ld: warning: libboost_date_time.so.1.68.0, needed by /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.1/../../../../lib/libdcp-1.0.so, not found (try using -rpath or -rpath-link) /usr/bin/ld: /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.1/../../../../lib/libdcp-1.0.so: referencia a `boost::system::detail::generic_category_ncx()' sin definir collect2: error: ld devolvió el estado de salida 1

Waf: Leaving directory `/tmp/yaourt-tmp-csm/aur-libsub/src/libsub-1.3.6/build' Build failed -> task in 'dumpsubs' failed with exit status 1 (run with -v to display more information) -> task in 'tests' failed with exit status 1 (run with -v to display more information) ==> ERROR: Se produjo un fallo en build(). Cancelando... ==> ERROR: Makepkg no ha podido compilar libsub. ==> ¿Reiniciar la compilación de libsub? [s/N] ==> ------------------------------------------

adsun commented on 2019-02-03 23:19

checksums and .SRCINFO need to be updated.

markusk commented on 2016-11-17 13:30

@mrdrogdrog;Thank you for the info. Fixed

TilmanV commented on 2016-11-17 12:34

libsub needs 'libcxml' >= 0.15.2. please update the pkgbuild