Package Details: libshout-idjc-git 898.4b1539c-1

Git Clone URL: https://aur.archlinux.org/libshout-idjc-git.git (read-only)
Package Base: libshout-idjc-git
Description: Libshout library plus some extensions for IDJC.
Upstream URL: http://idjc.sourceforge.net/
Licenses: LGPL
Conflicts: libshout-idjc
Replaces: libshout
Submitter: robertfoster
Maintainer: robertfoster
Last Packager: robertfoster
Votes: 3
Popularity: 0.000001
First Submitted: 2012-07-12 18:11
Last Updated: 2017-11-18 19:37

Latest Comments

Roken commented on 2016-10-24 18:15

I have the same problem as Zoschel with packer

configure: error: Package requirements (shout-idjc) were not met:

No package 'shout-idjc' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables SHOUTIDJC_CFLAGS
and SHOUTIDJC_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Zoschel commented on 2016-03-02 14:31

Build Fails

yaourt -S libshout-idjc-git

checking for canonicalize_file_name... yes
checking for SHOUTIDJC... no
configure: error: Package requirements (shout-idjc) were not met:

No package 'shout-idjc' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables SHOUTIDJC_CFLAGS
and SHOUTIDJC_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

SuaveIV commented on 2013-11-03 13:04

build fails

configure.ac:279: error: required file 'doc/Makefile.in' not found
Makefile.am:1: error: required directory ./doc does not exist
c/Makefile.am: installing './depcomp'
python/Makefile.am:12: installing './py-compile'
autoreconf: automake failed with exit status: 1

madjo commented on 2013-06-22 10:56

The PKGBUILD needs updating. The current version fails at the package() level. the " cd libshout-idjc" needs to be repeated, because the correct Makefile one directory further down. Same with pkgver().

Here's the correct version:

# Mantainer: M0Rf30
pkgname=libshout-idjc-git
pkgver=705.e9dab75
pkgrel=1
pkgdesc="Libshout-idjc is libshout plus some extensions for IDJC."
arch=(i686 x86_64)
url="http://idjc.sourceforge.net/"
depends=('libvorbis' 'libtheora' 'speex')
makedepends=('git')
options=('!libtool' '!emptydirs')
source=('libshout-idjc::git://idjc.git.sourceforge.net/gitroot/idjc/idjc/')
license=('LGPL')

build()
{
cd libshout-idjc
./bootstrap
cd libshout-idjc
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
make LDFLAGS+=-lspeex
}

package() {
cd libshout-idjc
cd libshout-idjc
make DESTDIR="${pkgdir}" install
}

pkgver() {
cd libshout-idjc
cd libshout-idjc
echo $(git rev-list --count master).$(git rev-parse --short master)
}

md5sums=('SKIP')