Package Details: libquotient 1:0.5.3.2-1

Git Clone URL: https://aur.archlinux.org/libquotient.git (read-only, click to copy)
Package Base: libquotient
Description: A Qt5 library to write cross-platform clients for Matrix
Upstream URL: https://github.com/quotient-im/libQuotient
Keywords: library matrix qt5 quotient
Licenses: LGPL2
Conflicts: libquotient
Provides: libquotient
Submitter: Scrumplex
Maintainer: aa13q
Last Packager: aa13q
Votes: 3
Popularity: 0.057816
First Submitted: 2019-07-15 16:52
Last Updated: 2020-04-30 19:31

Latest Comments

remspoor commented on 2020-06-14 14:27

While trying to install aur/vte3-notification i got an error (see aur package for that).

It looks like the header files are installed in a sub-optimal location.

Please consider a small change suggested by packager @mydongistiny to move the header files by adding:

--- PKGBUILD.orig   2020-06-14 15:54:32.692531104 +0200
+++ PKGBUILD-libquotient    2020-06-14 16:12:09.550706330 +0200
@@ -25,6 +25,7 @@
     cmake .. \
         -DCMAKE_INSTALL_PREFIX=/usr \
         -DCMAKE_INSTALL_LIBDIR=lib \
+        -DCMAKE_INSTALL_INCLUDEDIR=include/qt \
         -DCMAKE_BUILD_TYPE=Release \
         -DBUILD_SHARED_LIBS=1

Building quaternion still works ;)

aa13q commented on 2020-04-30 19:31

@blx32, thank you! Added arm arch

blx32 commented on 2020-04-30 18:35

Please add aarch64, it is compatible.

aa13q commented on 2020-04-26 11:22

my bad! Fixed and re-checked, should be fixed now

Fanch commented on 2020-04-26 10:39

https://github.com/quotient-im/libQuotient/archive/0.5.3.3.tar.gz does not exist Last version is 0.5.3.2

Maybe you should set:

pkgver=0.5.3.2
source=("https://github.com/quotient-im/libQuotient/archive/${pkgver}.tar.gz")
... and remove other ref to ${pkgrel}

And it look like it may not be a good practice to use ${pkgrel} as a version for downloading archive, as it not related to software version, but more related to PKGBUILD version

aa13q commented on 2020-04-24 19:15

got it! stupid me who have messed up the epoch so easily :)

RubenKelevra commented on 2020-04-24 19:01

Yep, that's correct.

Remember that the epoch needs to be kept forever, when you remove it, it would default to 0, meaning the next version is considered older.

aa13q commented on 2020-04-24 18:22

RubenKelevra, my bad, thank you very much! Added epoch (hope I did it right). Related discussion: https://aur.archlinux.org/packages/quaternion/#comment-741145

RubenKelevra commented on 2020-04-24 17:01

You can't just revert the version, you must add epoch, to force the downgrade.

Additionally, stable packages must not upgrade to beta version, except under some very rare circumstances:

"Stable packages package stable releases: Release candidates (i.e. 1.0.0-rc1), alpha (e.g. 1.0.0-alpha1) and beta (e.g. 1.0.0-beta1) releases are not allowed and are only to be used under the following circumstances:"

https://wiki.archlinux.org/index.php/Arch_package_guidelines#Package_versioning

aa13q commented on 2020-04-23 10:33

reverted back to 0.5.3-2 since quaternion build is not ready for the 0.6-beta1 yet