Package Details: libqglviewer 2.7.1-1

Git Clone URL: https://aur.archlinux.org/libqglviewer.git (read-only)
Package Base: libqglviewer
Description: C++ library based on Qt that eases the creation of OpenGL 3D viewers
Upstream URL: http://www.libqglviewer.com/
Keywords: OpenGL
Licenses: GPL2, custom, GPL3
Conflicts: libqglviewer-qt4
Submitter: ilpianista
Maintainer: gian
Last Packager: gian
Votes: 13
Popularity: 0.000000
First Submitted: 2009-10-17 21:36
Last Updated: 2017-12-11 17:49

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

gian commented on 2012-11-07 22:16

Hi Laurent,

I added the line you suggested to the PKGBUILD and it work fine on the x86_64 system, thanks.

As for the problem with the GLU dependency, as far as I remember, I already notified to upstream about it and the problem is fixed in 2.3.17. Anyway, I noted that the PKGBUILD should depend also on 'mesa'

Anonymous comment on 2012-10-24 19:27

Hi,

The missing "-L../QGLViewer" option seems due to the fact that the build procedure doesn't handle correctly simultaneous make jobs.
options=(!makeflags) into the PKGBUILD solved the problem for me.

Qt 4.8 also dropped its GLU dependency. The PKGBUILD should thus depend on 'glu'.
Moreover, the QGLViewer.pro file needs to be patched to include a QMAKE_LIBS_OPENGL *= -lGLU line inside the unix section (but this is a libQGLViewer bug, so it should be fixed upstream).

Regards,
Laurent

gian commented on 2012-09-21 21:27

Hi Ricardo,

the error seem to depend on libqglviewer itself.

The makefile miss the "-L../QGLViewer" option for the g++ when linking the designer plugin, but the option is present on 32 bit machine. I already notified the author about the problem.

Unluckily, since I have not a 64 bit machine on hand, for now I have not a clear solution other than to download the package and build it manually (with makepkg), manually patching the designer plugin Makefile.

bye
Gianluca

Anonymous comment on 2012-09-19 20:51

Hi gian.

There's a new version 2.3.17, but I'm not able to compile 2.3.16 neither 2.3.17.
The error is the same in any case:


g++ -m64 -Wl,-O1,--sort-common,--as-needed,-z,relro -Wl,-O1 -shared -o libqglviewerplugin.so .obj/qglviewerPlugin.Qt4.o .obj/moc_qglviewerPlugin.Qt4.o -L/usr/X11R6/lib64 -L/usr/lib -L/usr/lib/qt/plugins/lib -lQGLViewer -lpthread -lGL -lGLU -lQtXml -lQtOpenGL -lQtGui -lQtCore -lQtDesigner
/usr/bin/ld: cannot find -lQGLViewer
collect2: error: ld devolvió el estado de salida 1
make[1]: *** [libqglviewerplugin.so] Error 1

Regards,

Ricardo

gian commented on 2012-01-17 22:46

Hi Wiz
I updated the package. Let me know if it compile.

Anonymous comment on 2012-01-16 13:38

Doesn't compile here. Had to remplace CXXLIBS to SUBLIBS in the PKGBUILD.

gian commented on 2011-09-05 19:17

Hi

Thanks for the comment.

I uploaded a new version of the package that correct the problem.
If it fail again, please send me the output of the makepkg -g command, thanks

bye
Gianluca

Anonymous comment on 2011-09-05 15:19

Hi!

I've got the following error trying to install libqglviewer:

==> Retrieving Sources...
-> Found libQGLViewer-2.3.10.tar.gz
==> Validating source files with md5sums...
libQGLViewer-2.3.10.tar.gz ... FAILED
==> ERROR: One or more files did not pass the validity check!
==> ERROR: Makepkg was unable to build libqglviewer.

The contents of PKGBUILD is as follows:

# Maintainer: Gianluca Montecchi <gian@grys.it>
# Contributor: Geoffroy Carrier <geoffroy.carrier@aur.archlinux.org>
# Contributor: Dmitriy Morozov <archlinux@foxcub.org>
# Contributor: Larry Hajali <larryhaja [at] gmail [dot] com>

pkgname=libqglviewer
_pkgname=libQGLViewer
pkgver=2.3.10
pkgrel=1
pkgdesc="C++ library based on Qt that eases the creation of OpenGL 3D viewers"
url="http://www.libqglviewer.com/"
depends=('qt')
arch=('i686' 'x86_64')
license=('GPL2' 'GPL3' 'custom')
source=("http://www.libqglviewer.com/src/${_pkgname}-${pkgver}.tar.gz")
md5sums=('617b298b98ae0c722d0caead74109c4b')

build()
{
cd ${_pkgname}-$pkgver

qmake -unix -o Makefile ${_pkgname}-${pkgver}.pro || return 1
make \
CFLAGS="-pipe ${CFLAGS} -D_REENTRANT -Wall -W -fPIC \$(DEFINES)" \
CXXFLAGS="-pipe ${CXXFLAGS} -D_REENTRANT -Wall -W -fPIC \$(DEFINES)" || return 1
}

package()
{
cd ${_pkgname}-$pkgver

make install INSTALL_ROOT="$pkgdir" || return 1

# Install license.
install -d -m 0755 "${pkgdir}"/usr/share/licenses/$pkgname/ || return 1
install -m 0644 LICENCE GPL_EXCEPTION "${pkgdir}"/usr/share/licenses/$pkgname/ || return 1
}

Your help would be appreciated.
piogun

gian commented on 2011-03-14 09:07

Since it seems that PyQGLViewer depend on python2 and python-opengl, I opted for a separate package since I don't see the point to force the installation of all the python2 packages if someone don't need them. As long as the package will be ported to python3, I will merge the two packages.

foxcub commented on 2011-03-10 23:37

Wait, I'm confused. This seems to defeat the purpose. I thought you'd include the Python bindings into this package. Now it's just a separate parallel package for libqglviewer. Is this what you intended?