Package Details: libpdfium-nojs 3809.r3.178b812ec8-1

Git Clone URL: https://aur.archlinux.org/libpdfium-nojs.git (read-only)
Package Base: libpdfium-nojs
Description: Open-source PDF rendering engine.
Upstream URL: https://pdfium.googlesource.com/pdfium/
Keywords: pdf
Licenses: BSD
Conflicts: libpdfium-bin
Provides: libpdfium
Submitter: selmf
Maintainer: selmf
Last Packager: selmf
Votes: 5
Popularity: 0.007727
First Submitted: 2017-07-30 18:14
Last Updated: 2019-08-02 13:03

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

dramm commented on 2019-02-02 17:24

It seems that a checksum needs to be updated.

==> Validating source files with md5sums...
    pdfium ... Skipped
    build ... Skipped
    buildtools ... Skipped
    libpdfium.pc ... Passed
    openjpeg.patch ... FAILED
==> ERROR: One or more files did not pass the validity check!

selmf commented on 2019-02-01 15:33

Yeah, that can happen. This package tracks the stable channel of Chromium, so whenever a new version is released there is some chance of breakage. When I introduced this mechanism this didn't happen too often, but it is getting more frequent. I probably should remove it and just manually track the "good" versions ;)

I've updated the patches, so compilation should work again.

m8D2 commented on 2019-02-01 03:41

Hi,I got this error:

patching file pdfium/third_party/BUILD.gn
Hunk #1 succeeded at 394 (offset 27 lines).
patching file pdfium/core/fxcodec/codec/codec_int.h
patching file pdfium/core/fxcodec/codec/ccodec_jpxmodule.cpp
Hunk #1 FAILED at 17.
Hunk #2 FAILED at 515.
Hunk #3 succeeded at 550 (offset 1 line).
2 out of 3 hunks FAILED -- saving rejects to file pdfium/core/fxcodec/codec/ccodec_jpxmodule.cpp.rej
patching file pdfium/core/fxcodec/codec/cjpx_decoder.h
patching file pdfium/BUILD.gn
Hunk #1 succeeded at 20 (offset -1 lines).
Hunk #2 succeeded at 76 (offset -1 lines).
==> ERROR: A failure occurred in prepare().
Aborting...
Error making: libpdfium-nojs

sandsmark commented on 2018-12-07 22:05

the patch fails on third_party/BUILD.gn, but looks like it should be trivial to redo.

selmf commented on 2018-09-16 16:29

Should be fixed now.

Epsilon commented on 2018-09-16 00:12

Currently broken "Hunk #2 FAILED at 511. Hunk #3 succeeded at 546 (offset -2 lines). 1 out of 3 hunks FAILED -- saving rejects to file pdfium/core/fxcodec/codec/fx_codec_jpx_opj.cpp.rej patching file pdfium/core/fxcodec/codec/cjpx_decoder.h Hunk #1 FAILED at 12."

selmf commented on 2018-06-01 23:11

Should be fixed now. Thanks for reporting!

icejack1 commented on 2018-06-01 23:00

Hi getting the following error when trying to update to latest version:

==> Starting build()... Done. Made 51 targets from 58 files in 276ms ninja: Entering directory `out/Release' ninja: error: '../../tools/generate_shim_headers/generate_shim_headers.py', needed by 'gen/shim_headers/icuuc_shim/appendable.h', missing and no known rule to make it ==> ERROR: A failure occurred in build(). Aborting...

selmf commented on 2018-05-02 11:00

This was caused by a change in the upstream build system. I've updated the package, it should work again now.

donbex commented on 2018-05-02 10:09

Trying to build the package I get the following error:

Your branch is up to date with 'origin/chromium/3359'.
==> Starting pkgver()...
==> Removing existing $pkgdir/ directory...
==> Starting build()...
ERROR at //BUILD.gn:105:1: Unknown function.
jumbo_shared_library("pdfium") {
^-------------------
==> ERROR: A failure occurred in build().
    Aborting...

I also tried rebuilding gn-bin, but it didn't help. Any idea what might be causing this? The last version I was able to compile was 3282.r6.b1040bcfc-1.