Package Details: libosmocore 1.3.0-1

Git Clone URL: https://aur.archlinux.org/libosmocore.git (read-only, click to copy)
Package Base: libosmocore
Description: core libs for osmocom
Upstream URL: http://bb.osmocom.org/trac/wiki/libosmocore
Licenses: GPL
Submitter: asdil12
Maintainer: asdil12
Last Packager: asdil12
Votes: 15
Popularity: 0.26
First Submitted: 2012-03-08 09:58
Last Updated: 2020-03-04 09:48

Latest Comments

1 2 Next › Last »

asdil12 commented on 2020-03-04 09:49

added the patches and fixed some missing deps.

GNUtoo commented on 2020-03-03 19:00

Hi, here are two patches:

From 0e5683310dbaaa148fdc531882b912ca47aaa95b Mon Sep 17 00:00:00 2001
From: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
Date: Tue, 3 Mar 2020 19:39:28 +0100
Subject: [PATCH 1/2] Update to version 1.3.0

Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
---
 PKGBUILD | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/PKGBUILD b/PKGBUILD
index 133de89..55af319 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
 # Maintainer: Dominik Heidler <dominik@heidler.eu>

 pkgname=libosmocore
-pkgver=1.0.1
+pkgver=1.3.0
 pkgrel=1
 pkgdesc="core libs for osmocom"
 arch=('x86_64' 'i686')
-- 
2.25.1

And:

From 3f886a66a1e1f93e4180cb505ecc7129e7b921dc Mon Sep 17 00:00:00 2001
From: Denis 'GNUtoo' Carikli GNUtoo@cyberdimension.org
Date: Tue, 3 Mar 2020 19:59:02 +0100
Subject: [PATCH 2/2] Add support for the armv7h architecture

Signed-off-by: Denis 'GNUtoo' Carikli GNUtoo@cyberdimension.org

PKGBUILD | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/PKGBUILD b/PKGBUILD index 55af319..a8aab5f 100644 --- a/PKGBUILD +++ b/PKGBUILD @@ -4,7 +4,7 @@ pkgname=libosmocore pkgver=1.3.0 pkgrel=1 pkgdesc="core libs for osmocom" -arch=('x86_64' 'i686') +arch=('armv7h' 'i686' 'x86_64') url="http://bb.osmocom.org/trac/wiki/libosmocore" license=('GPL') groups=() -- 2.25.1

asdil12 commented on 2018-09-14 09:30

done

rexhunt commented on 2018-09-14 09:13

This wouldn't build without talloc installed. Perhaps this should be added to the makedepends?

asdil12 commented on 2016-09-02 14:22

done

pandan commented on 2016-08-30 23:26

please add 'pkg-config' to makedepends. thanks

lynxis commented on 2016-05-10 11:38

there is a new version 0.9

asdil12 commented on 2015-05-27 15:01

updated to 0.8.0

yuvadm commented on 2015-05-24 11:55

This package requires upgrading to v0.8.0. Additionally, the ldconfig calls in the .install file are redundant and considered bad practice.

rumpelsepp commented on 2013-05-03 08:58

Ahh, very cool. Didn't notice this... :)