Package Details: liboping 1.10.0-14

Git Clone URL: https://aur.archlinux.org/liboping.git (read-only, click to copy)
Package Base: liboping
Description: C library to generate ICMP echo requests, better known as "ping packets"
Upstream URL: https://noping.cc/
Licenses: GPL
Submitter: arojas
Maintainer: lilydjwg (lilac)
Last Packager: lilac
Votes: 6
Popularity: 2.18
First Submitted: 2021-05-08 09:15
Last Updated: 2021-07-08 20:32

Dependencies (4)

Required by (4)

Sources (2)

Latest Comments

1 2 Next › Last »

triz3n commented on 2021-07-08 02:05

@lilydjwg its yours!

lilydjwg commented on 2021-07-07 14:35

Hi triz3n, I can help with this package if you're willing.

mattelacchiato commented on 2021-07-07 06:53

The latest update installs "noping" again. Thank you! But sadly, I can't run this as normal user: ping_send failed: Operation not permitted

Normal ping is no problem...

rsa commented on 2021-07-06 20:41

@triz3n cool, the only thing you needed to change was revert the make command in the package function to be make DESTDIR="${pkgdir}" install instead of just make DESTDIR="${pkgdir}". The rest of the changes can be kept.

triz3n commented on 2021-07-06 00:37

@rsa @mattelacchiato I have reverted everything back to the way it was when I picked up this package. Sorry for the issues.

rsa commented on 2021-07-05 22:44

This package now installs nothing since the make install step was removed. It is an empty package (0 bytes).

mattelacchiato commented on 2021-07-02 13:39

I've just installed liboping, but the "noping" command is missing...

triz3n commented on 2021-07-01 19:07

@lilydjwg I removed the install script from the PKGBUILD and removed the file from the repo. Namcap doesn't show anything on the PKGBUILD and I was able to install the package using makepkg -si. After pushing to the repo I installed with trizen for good measure and again didn't receive any errors. So you should be all set!

Thank you for reaching out and letting me know!

lilydjwg commented on 2021-07-01 13:32

The whole install script can be removed. Currently there is an error saying post_upgrade isn't found.

goodmen commented on 2021-06-28 01:33

Why this pkg is removed from the community by arojas in [2021-05-08 09:15 +0000] ?