Package Details: libnm-iwd 1.32.0-1

Git Clone URL: https://aur.archlinux.org/networkmanager-iwd.git (read-only, click to copy)
Package Base: networkmanager-iwd
Description: NetworkManager client library with iwd backend
Upstream URL: https://wiki.gnome.org/Projects/NetworkManager
Licenses: LGPL
Provides: libnm.so
Submitter: digitalone
Maintainer: buzo
Last Packager: buzo
Votes: 16
Popularity: 1.05
First Submitted: 2019-08-10 10:04
Last Updated: 2021-06-18 11:39

Dependencies (38)

Required by (1)

Sources (2)

Pinned Comments

digitalone commented on 2019-08-10 10:37

This is a modified package configured to get NetworkManager working exclusively with iwd. Main difference with upstream version is that iwd is required and wpa_supplicant is not needed (so you can uninstall it); iwd seems more reliable on certain wireless cards, so someone could prefer it in place of wpa_supplicant.

It's recommended to enable systemd iwd.service at boot: systemctl enable iwd.service

Tested with Plasma NM system tray applet (plasma-nm), it's working.

Note that wpa_supplicant is still needed to build the package, but you can uninstall it after the building stage.

Latest Comments

1 2 3 Next › Last »

cubethethird commented on 2021-06-19 02:39

I can no longer install libnm-iwd as it no longer provides libnm, but instead only libnm.so, and it complains that this breaks dependencies for other packages. Is there a particular reason for this change?

buzo commented on 2021-05-13 09:06

maksverver: Fixed, thanks. (Please click on “Flag package out-of-date” next time.)

maksverver commented on 2021-05-12 18:40

I had to bump ppp_version to 2.4.9 to install this, which is the current version of ppp in the core repo. Maybe a pkgrel update is in order?

Gadgethm commented on 2021-02-01 23:30

I also see the same issue as cubethethird, hopefully will be fixed in the next update.

cubethethird commented on 2021-01-17 20:57

It's looking like there's an issue with the package version (possibly 1 too many characters in the hash). When running the pkgver function, the version gets updated to 1.28.1dev+7+g3f5df3cdc-1, which is considered to be older than the stated version in the PKGBUID of 1.28.1dev+7+g3f5df3cdc6-2. As a result, each time I build and update, I am still informed that the upstream is newer than the current.

buzo commented on 2021-01-04 12:54

Thanks, frebib – fixed.

frebib commented on 2021-01-04 12:10

error: failed to prepare transaction (could not satisfy dependencies)
:: installing libnm-iwd (1.28.1dev+7+g3f5df3cdc6-1) breaks dependency 'libnm' required by blueman
:: installing libnm-iwd (1.28.1dev+7+g3f5df3cdc6-1) breaks dependency 'libnm' required by libnma
:: installing libnm-iwd (1.28.1dev+7+g3f5df3cdc6-1) breaks dependency 'libnm' required by networkmanager-openconnect
:: installing libnm-iwd (1.28.1dev+7+g3f5df3cdc6-1) breaks dependency 'libnm' required by tracker3-miners

The libnm provides needs to be re-added to the libnm-iwd package

Gatenkaas commented on 2020-12-05 11:27

There is a bug when using IWD as a backend in combination with iwlwifi, for instance with a Intel's AX200 wireless adapter. If you do not disable the iwd.service afterwards then it crashes : WARNING: CPU: 7 PID: 492 at net/wireless/nl80211.c:7260 nl80211_get_reg_do+0x1cd/0x1f0. This is because 90-networkmanager.conf is triggering to activate the service also. See Kernel.org Bugzilla – Bug 208599

loki7990 commented on 2020-09-29 17:33

Looks like it s working! Thanks so much @ndowens04

Anonymous comment on 2020-09-23 19:15

Should be fixed now