Package Details: libmagick6 6.9.12.8-1

Git Clone URL: https://aur.archlinux.org/imagemagick6.git (read-only, click to copy)
Package Base: imagemagick6
Description: An image viewing/manipulation program (version 6; library)
Upstream URL: https://legacy.imagemagick.org/
Licenses: custom
Submitter: arojas
Maintainer: yochananmarqos
Last Packager: yochananmarqos
Votes: 5
Popularity: 1.51
First Submitted: 2021-01-29 14:32
Last Updated: 2021-04-17 22:49

Dependencies (37)

Sources (2)

Latest Comments

1 2 Next › Last »

ector commented on 2021-04-09 21:04

Hi, why have this orphaned?? Orphaned AUR Packages: libmagick6

ArchNewbie commented on 2021-03-07 23:36

I have the same problem like @potens

Resolved it by building in a clean chroot. However, @xuanruiqi, you should make it possible to upgrade without involving clean chroot

nilsw commented on 2021-03-05 09:54

I also stumbled across an issue during packaging. It seemed like a Makefile was outdated had to be recreated. Strangely I couldn't reproduce the error, both simply retrying and clean rebuilding both worked afterwards.

xuanruiqi commented on 2021-03-03 22:55

I know nothing about Manjaro, and I can't help with Manjaro issues in general. Try using makepkg and/or building in a clean chroot.

Domarius commented on 2021-03-03 22:54

Same error as the others, but I'm installing through Manjaro's "Add/Remove Software" manager. Tried a few times with the same result, even after rebooting.

xuanruiqi commented on 2021-02-28 00:03

This is really strange. Have you tried building in a clean chroot? For what it's worth, I have never successfully reproduced this bug, so I can't do anything at the moment. Looks like the problem is with perl, but perl is an implicit dependency of this package (and all AUR packages), because it's a dependency of autoconf and automake in base-devel. Maybe check that the base-devel group is correctly installed?

potens commented on 2021-02-27 21:25

Hello @xuanruiqi, Thank you for the AUR but this is to let you know, I've the same problem as @kido007 and @mmkodali

For the records, I think the compilation went well, then tests are OK, but it fail at the make install stage (not sure, but I think)

Deleted the build dir also and retried, same result:

libtool: install: (cd /tmp/imagemagick6/src/ImageMagick6-6.9.12-1; /bin/sh "/tmp/imagemagick6/src/ImageMagick6-6.9.12-1/libtool"  --silent --tag CC --mode=relink gcc -I/usr/include/libxml2 -I/usr/include/cairo -I/usr/include/lzo -I/usr/include/libpng16 -I/usr/include/freetype2 -I/usr/include/harfbuzz -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/librsvg-2.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libmount -I/usr/include/blkid -I/usr/include/gdk-pixbuf-2.0 -pthread -I/usr/include/cairo -I/usr/include/lzo -I/usr/include/libpng16 -I/usr/include/freetype2 -I/usr/include/harfbuzz -I/usr/include/pixman-1 -I/usr/include/libraw -I/usr/include/libpng16 -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/harfbuzz -I/usr/include/freetype2 -I/usr/include/libpng16 -I/usr/include/libmount -I/usr/include/blkid -I/usr/include/fribidi -I/usr/include/cairo -I/usr/include/lzo -I/usr/include/pixman-1 -pthread -I/usr/include/OpenEXR -pthread -I/usr/include/lqr-1 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/openjpeg-2.4 -I/usr/include/freetype2 -I/usr/include/libpng16 -I/usr/include/harfbuzz -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/fribidi -I/usr/include/freetype2 -I/usr/include/libpng16 -I/usr/include/harfbuzz -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/freetype2 -I/usr/include/libpng16 -I/usr/include/harfbuzz -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -fopenmp -Wall -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -fexceptions -pthread -DMAGICKCORE_HDRI_ENABLE=1 -DMAGICKCORE_QUANTUM_DEPTH=16 -no-undefined -export-symbols-regex ".*" -shared -module -avoid-version -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now -o coders/xwd.la -rpath /usr/lib/ImageMagick-6.9.12/modules-Q16HDRI/coders coders/xwd_la-xwd.lo magick/libMagickCore-6.Q16HDRI.la -lSM -lICE -lX11 -inst-prefix-dir /tmp/imagemagick6/pkg/libmagick6)
libtool: install: /usr/bin/install -c coders/.libs/xwd.soT /tmp/imagemagick6/pkg/libmagick6/usr/lib/ImageMagick-6.9.12/modules-Q16HDRI/coders/xwd.so
libtool: install: /usr/bin/install -c coders/.libs/xwd.lai /tmp/imagemagick6/pkg/libmagick6/usr/lib/ImageMagick-6.9.12/modules-Q16HDRI/coders/xwd.la
libtool: warning: remember to run 'libtool --finish /usr/lib/ImageMagick-6.9.12/modules-Q16HDRI/coders'
make[2]: Leaving directory '/tmp/imagemagick6/src/ImageMagick6-6.9.12-1'
make[1]: Leaving directory '/tmp/imagemagick6/src/ImageMagick6-6.9.12-1'
mv: cannot stat '/tmp/imagemagick6/pkg/libmagick6/usr/lib/perl5': No such file or directory
==> ERROR: A failure occurred in package_libmagick6().
    Aborting...

Tried with pikaur and makepkg

kido007 commented on 2021-02-10 13:21

Hello and thank you for creating this repo. I have the same failure as the one reported by @mmkodali

mv: cannot stat '/home/username/tmp/imagemagick6/pkg/libmagick6/usr/lib/perl5': No such file or directory ==> ERROR: A failure occurred in package_libmagick6().

Tried to delete the folder and retry, same result.

zorggy commented on 2021-02-06 19:23

@arojas You are right, the exact error was:

Cloning into 'libmagick6'...
warning: You appear to have cloned an empty repository.
==> ERROR: PKGBUILD does not exist.

But it's OK now, thank you.

arojas commented on 2021-02-05 07:43

@zorggy it's a git repo, not a web page.