Package Details: libkipi-git r1162.a6ecdba-1

Git Clone URL: https://aur.archlinux.org/libkipi-git.git (read-only, click to copy)
Package Base: libkipi-git
Description: An interface to use kipi-plugins from a KDE application
Upstream URL: http://www.kde.org
Licenses: GPL, LGPL, FDL
Groups: digikamsc-git
Conflicts: libkipi
Provides: libkipi
Submitter: Sevenseven
Maintainer: Sevenseven
Last Packager: Sevenseven
Votes: 27
Popularity: 0.30
First Submitted: 2011-03-14 09:25
Last Updated: 2015-11-17 15:31

Latest Comments

aviallon commented on 2020-06-15 21:01

Package doesn't build, and pkgver is not right.

diff --git a/PKGBUILD b/PKGBUILD
index 26ac57f..3bc1599 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=libkipi-git
-pkgver=r1162.a6ecdba
+pkgver=v20.04.2.r0.g51e8206
pkgrel=1
pkgdesc='An interface to use kipi-plugins from a KDE application'
arch=('i686' 'x86_64')
@@ -10,13 +10,13 @@ makedepends=('git' 'extra-cmake-modules-git' 'kdoctools')
conflicts=('libkipi')
provides=('libkipi')
groups=('digikamsc-git')
-source=('libkipi::git+git://anongit.kde.org/libkipi')
+source=('libkipi::git+https://anongit.kde.org/libkipi')
md5sums=('SKIP')
install=libkipi-git.install

pkgver() {
cd "${srcdir}/libkipi"
-  printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+  git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}

prepare() {
@@ -40,4 +40,4 @@ build() {
package() {
cd "${srcdir}/build"
make DESTDIR="${pkgdir}" install
-}
\ No newline at end of file
+}

pavbaranov commented on 2015-10-16 13:24

libkipi (master) is merged with frameworks now. It's imposible to build libkipi-git with old, KDE4 dependiences.

sl1pkn07 commented on 2015-01-27 16:58

yes because have common /usr/share/icons/hicolor with libkipi [extra]. but libkipi-frameworks-git not replace libkipi (one is Qt4(libkipi) and other is Qt5(libkipi-frameworks)

greetings

cruiseliu commented on 2015-01-27 16:37

conflicts with libkipi

arojas commented on 2014-12-06 18:42

missing kparts dependency

Anonymous comment on 2011-03-16 12:54

kipi-plugins-git has conflict with a kdegraphics-libs and can not be installed without removing kipi-plugins-git as well. So the digiKam 2.0 installation has depency loop and impossible to install.