Package Details: libjxl-git 0.3.7.r294.g50660ed-1

Git Clone URL: https://aur.archlinux.org/libjxl-git.git (read-only, click to copy)
Package Base: libjxl-git
Description: JPEG XL image format reference implementation (git version)
Upstream URL: https://jpeg.org/jpegxl/
Keywords: jpeg-xl
Licenses: BSD
Conflicts: libjpeg-xl-git, libjxl
Provides: libjpeg-xl-git, libjxl, libjxl.so, libjxl_jni.so, libjxl_threads.so
Replaces: libjpeg-xl-git
Submitter: dbermond
Maintainer: dbermond
Last Packager: dbermond
Votes: 7
Popularity: 0.76
First Submitted: 2021-06-02 18:30
Last Updated: 2021-07-31 00:33

Dependencies (32)

Required by (4)

Sources (11)

Latest Comments

1 2 3 4 5 6 Next › Last »

dbermond commented on 2021-06-06 01:39

@silverhikari That's because highway on-tree dependency was updated to 0.12.2 by upstream. This version installs headers in different directories compared to 0.12.0. I've pushed an update, and now the package is using highway from system again. Building fine now.

silverhikari commented on 2021-06-05 23:10

i get a rm error when compiling, so here is what is happening rm: cannot remove '/var/tmp/pamac-build-silver/libjxl-git/pkg/libjxl-git/usr/include/contrib': No such file or directory

dbermond commented on 2021-06-03 15:36

@andrius4669 Not needed. Maintainer of qt-jpegxl-image-plugin-git needs to update the package dependencies, as it currently needs the git master branch of libjxl, and does not build with the latest stable libjxl 0.3.7 release. So it should depend on libjxl-git/libjpeg-xl-git and not on libjxl/libjpeg-xl, at least for now.

andrius4669 commented on 2021-06-03 15:17

should probably provide libjpeg-xl too, as I can't install qt-jpegxl-image-plugin-git now.

dbermond commented on 2021-04-23 12:44

@andrius4669 I added asciidoc on the libjpeg-xl 0.3.7 update but forgot to add it here. Package updated, thanks.

andrius4669 commented on 2021-04-22 08:06

CMake Warning at CMakeLists.txt:300 (message):
  asciidoc was not found, the man pages will not be installed.

dbermond commented on 2021-03-02 01:32

@andrea.denisse just run makepkg and it will automatically update pkgver to the latest upstream commit. No intervention is needed here currently.

denisse commented on 2021-03-01 17:02

Hello, the current version of this package contains multiple vulnerabilities. Affected versions are v0.3.1 and earlier. Please update to the latest version.

nathanielcwm commented on 2021-02-06 13:56

Oh my bad didn't notice it was a split package.

dbermond commented on 2021-02-06 12:31

@nathanielcwm It's already there. Please look carefully.