Package Details: libim 3.13-1

Git Clone URL: https://aur.archlinux.org/libim.git (read-only)
Package Base: libim
Description: Imaging toolkit library
Upstream URL: https://www.tecgraf.puc-rio.br/im/
Licenses: MIT
Submitter: None
Maintainer: blueowl
Last Packager: blueowl
Votes: 3
Popularity: 0.000001
First Submitted: 2010-07-22 08:52
Last Updated: 2019-01-11 11:28

Latest Comments

1 2 Next › Last »

blueowl commented on 2019-02-07 13:41

@wilmfone the message "../lib/Linux420_64/libim_process.so: file not recognized" looks suspicious.
It could be caused by various reasons. Please check that you have clean source directory, have enough memory and disk space.

If you still fail to build libim, I would like to ask you to continue troubleshooting via my email (not to spam these comments too much).
Some tips:
- Try to get PKGBUILD into fresh directory
- run makepkg with C locale to have English error messages
LC_ALL=C makepkg -L
- capture the log from the build
pkgbase-pkgver-pkgrel-arch-<function>.log
- what is your machine like: uname -a
- any other relevant info about how do you build, what (if anything) is special in your system, etc.

PS: There are many warnings while compiling the source. Even if they are ugly, mostly they are harmless and do not cause any problems. Nonetheless, I have been analyzing them and reporting to upstream.

wilmfone commented on 2019-02-04 15:13

New and more errors when watching in stderr during "makepkg": /usr/bin/ld: ../lib/Linux420_64/libim_process.so: file not recognized: file truncated collect2: Fehler: ld gab 1 als Ende-Status zurück make[1]: [../tecmake.mak:1607: ../lib/Linux420_64/libim_fftw.so] Fehler 1 make[1]: Das Ziel „build“ wurde wegen Fehlern nicht aktualisiert. make: [Makefile:22: im_fftw] Fehler 2 /usr/bin/ld: ../obj/im_jp2/Linux420_64/jas_stream.o: in function jas_stream_tmpfile': jas_stream.c:(.text+0x6c2): Warnung:the use oftmpnam' is dangerous, better use `mkstemp

Any ideas?

wilmfone commented on 2019-02-04 14:04

Problems when compiling im:

Tecmake: linking libim_lzo.so ... gcc -shared -o ../lib/Linux420_64/libim_lzo.so ../obj/im_lzo/Linux420_64/im_lzo.o ../obj/im_lzo/Linux420_64/minilzo.o -L../lib/Linux420_64 -lim -lpng -lz -lm /usr/bin/ld: -lim not found.

Can anyone help me what flag is missing here? Looks quite generic and missing either as a patch of the original sources...

ktamp commented on 2018-03-05 21:12

Please add 'lsb-release' to Makedepends list.

daurnimator commented on 2018-02-28 23:33

md5sums changed?

<hr>

EDIT: Nevermind, sourceforge is down and serving:

We're sorry -- the Sourceforge site is currently in Disaster Recovery mode, and currently requires the use of javascript to function. Please check back later.

haawda commented on 2017-09-04 20:50

orphaned and given to blueowl

blueowl commented on 2017-09-04 11:41

haawda, I've sent you patches to fix some issues with libim and libcd packages via e-mail. Would you commit them, please.
The patches are available here as well:
https://paste.ee/p/TLMsz
https://paste.ee/p/43M5D

PS:if you are not interested in the packages or don't have time for it, I am happy to maintain them.

daurnimator commented on 2017-06-26 06:42

Works with `makepkg -C` but not with under `aurbuild` (where I get "install: will not overwrite just-created" errors). any idea why?

haawda commented on 2017-06-06 05:53

The ??? seems to be the kernel version number. So this PKGBUILD produces different packages when built under linux-lts. Great idea.

daurnimator, I get a similar thing when I do not remove things from a previous build.

daurnimator commented on 2017-06-06 04:18

==> Starting package()...
install: will not overwrite just-created '/home/daurnimator/.cache/aursync/libim/pkg/libim/usr/lib/libim.a' with '/home/daurnimator/.cache/aursync/libim/src/im/lib/Linux411_64/libim.a'
install: will not overwrite just-created '/home/daurnimator/.cache/aursync/libim/pkg/libim/usr/lib/libim_fftw.a' with '/home/daurnimator/.cache/aursync/libim/src/im/lib/Linux411_64/libim_fftw.a'
install: will not overwrite just-created '/home/daurnimator/.cache/aursync/libim/pkg/libim/usr/lib/libim_fftw.so' with '/home/daurnimator/.cache/aursync/libim/src/im/lib/Linux411_64/libim_fftw.so'
install: will not overwrite just-created '/home/daurnimator/.cache/aursync/libim/pkg/libim/usr/lib/libim_jp2.a' with '/home/daurnimator/.cache/aursync/libim/src/im/lib/Linux411_64/libim_jp2.a'
install: will not overwrite just-created '/home/daurnimator/.cache/aursync/libim/pkg/libim/usr/lib/libim_jp2.so' with '/home/daurnimator/.cache/aursync/libim/src/im/lib/Linux411_64/libim_jp2.so'
install: will not overwrite just-created '/home/daurnimator/.cache/aursync/libim/pkg/libim/usr/lib/libim_lzo.a' with '/home/daurnimator/.cache/aursync/libim/src/im/lib/Linux411_64/libim_lzo.a'
install: will not overwrite just-created '/home/daurnimator/.cache/aursync/libim/pkg/libim/usr/lib/libim_lzo.so' with '/home/daurnimator/.cache/aursync/libim/src/im/lib/Linux411_64/libim_lzo.so'
install: will not overwrite just-created '/home/daurnimator/.cache/aursync/libim/pkg/libim/usr/lib/libim_process.a' with '/home/daurnimator/.cache/aursync/libim/src/im/lib/Linux411_64/libim_process.a'
install: will not overwrite just-created '/home/daurnimator/.cache/aursync/libim/pkg/libim/usr/lib/libim_process_omp.a' with '/home/daurnimator/.cache/aursync/libim/src/im/lib/Linux411_64/libim_process_omp.a'
install: will not overwrite just-created '/home/daurnimator/.cache/aursync/libim/pkg/libim/usr/lib/libim_process_omp.so' with '/home/daurnimator/.cache/aursync/libim/src/im/lib/Linux411_64/libim_process_omp.so'
install: will not overwrite just-created '/home/daurnimator/.cache/aursync/libim/pkg/libim/usr/lib/libim_process.so' with '/home/daurnimator/.cache/aursync/libim/src/im/lib/Linux411_64/libim_process.so'
install: will not overwrite just-created '/home/daurnimator/.cache/aursync/libim/pkg/libim/usr/lib/libim.so' with '/home/daurnimator/.cache/aursync/libim/src/im/lib/Linux411_64/libim.so'
==> ERROR: A failure occurred in package().
Aborting...