Package Details: libhandy-git 0.80.0.r14.g2bfaeb2-1

Git Clone URL: https://aur.archlinux.org/libhandy-git.git (read-only, click to copy)
Package Base: libhandy-git
Description: Library full of GTK+ widgets for mobile phones
Upstream URL: https://gitlab.gnome.org/GNOME/libhandy
Keywords: GTK Librem5 mobile phone Purism responsive
Licenses: LGPL2.1
Conflicts: libhandy
Provides: libhandy
Submitter: flipflop97
Maintainer: flipflop97
Last Packager: flipflop97
Votes: 3
Popularity: 0.000014
First Submitted: 2018-08-30 13:21
Last Updated: 2020-05-22 21:18

Required by (49)

Sources (1)

Latest Comments

flipflop97 commented on 2020-05-14 13:51

@rhysperry111

Libhandy currently doesn't compile with the newest version of Glade. A pull request is pending but not yet merged:
https://source.puri.sm/Librem5/libhandy/-/merge_requests/451

I made a packages that compiles without glade support which you could use in the meantime:
libhandy-glade-catalog-disabled-git

rhysperry111 commented on 2020-05-14 11:00

Hi, I get an error while building:

../libhandy/glade/glade-hdy-swipe-group.c:48:46: error: ‘GPC_OBJECT_DELIMITER’ undeclared (first use in this function)
   48 |           g_strdup_printf ("%s%s%s", string, GPC_OBJECT_DELIMITER,

flipflop97 commented on 2018-12-16 13:12

@simona Hmm that's strange, I'm not able to reproduce that. You can try building the package with --nocheck and see if the resulting package works correctly. Maybe it's also a good idea to report this to the issue tracker of libhandy itself.

simona commented on 2018-12-16 12:45

3/6 test-dialer-cycle-button FAIL 0.73 s (killed by signal 5 SIGTRAP)

flipflop97 commented on 2018-09-27 11:15

Thanks, added!

yangtsesu commented on 2018-09-25 11:47

make depends on vala