Package Details: libgit2-git 2:0.27.0.rc1.r0.g809b0ca6b-1

Git Clone URL: https://aur.archlinux.org/libgit2-git.git (read-only)
Package Base: libgit2-git
Description: A linkable library for Git
Upstream URL: https://libgit2.github.com/
Licenses: GPL2
Conflicts: libgit2
Provides: libgit2
Submitter: herve
Maintainer: Nukesor
Last Packager: Nukesor
Votes: 10
Popularity: 0.000002
First Submitted: 2009-09-13 14:25
Last Updated: 2018-02-22 11:38

Required by (45)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3

msierks commented on 2012-04-25 14:38

Fix is to build with "-DBUILD_CLAR=OFF" option. The test suite has errors in it at the moment.

msierks commented on 2012-04-25 14:09

I cannot get this package to build. Could you please fix ?

herve commented on 2011-12-29 09:30

Thanks for the report.

I lost interest in libgit2 months ago, feel free to adopt the package.

Though I'm happy to see libgit2 has evolved a lot since then.

falconindy commented on 2011-12-27 21:17

Broken package due to build system change months ago. New PKGBUILD below with:

- fixed arch (anything that compiles is _not_ an 'any' package)
- fixed depends (needs zlib)
- fixed build function (use cmake, not waf)
- better description from upstream
- package function (because repackaging is good)

http://sprunge.us/fWaA