Package Details: libgit2-git 2:0.27.0.rc1.r0.g809b0ca6b-1

Git Clone URL: https://aur.archlinux.org/libgit2-git.git (read-only, click to copy)
Package Base: libgit2-git
Description: A linkable library for Git
Upstream URL: https://libgit2.github.com/
Licenses: GPL2
Conflicts: libgit2
Provides: libgit2
Submitter: herve
Maintainer: Nukesor
Last Packager: Nukesor
Votes: 10
Popularity: 0.000001
First Submitted: 2009-09-13 14:25
Last Updated: 2018-02-22 11:38

Required by (46)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

thestinger commented on 2013-05-31 23:06

Python now cares more about the system locale, so that's the problem. Using an old version that doesn't care about the system locale may work but it's not a long-term solution to the problem.

stefano.facchini commented on 2013-05-31 22:58

thestinger, I don't know about the en_US.UTF-8 locale, but using python2 (with configure flag -DPYTHON_EXECUTABLE:FILEPATH=/usr/bin/python2) solves the problem

stefano.facchini commented on 2013-05-31 22:55

thestinger, I don't know about the en_US.UTF-8 locale, but using python2 (with configure flag -DPYTHON_EXECUTABLE:FILEPATH=/usr/bin/python2) solves the problem

stefano.facchini commented on 2013-05-31 22:50

thestinger, I don't know about the en_US.UTF-8 locale, but using python2 (with configure flag -DPYTHON_EXECUTABLE:FILEPATH=/usr/bin/python2) solves the problem

thestinger commented on 2013-05-31 22:22

You need the en_US.UTF-8 locale generated. It's one of the two locales generated in the root used for building with devtools, so the package has to hardcode it.

stefano.facchini commented on 2013-05-31 22:15

Build fails for me:

Linking C shared library libgit2.so
[ 24%] Built target git2
[ 24%] Generating tests-clar/clar.suite
Traceback (most recent call last):
File "generate.py", line 240, in <module>
suite.load(options.force)
File "generate.py", line 185, in load
if not self.modules[name].refresh(path):
File "generate.py", line 122, in refresh
raw_content = fp.read()
File "/usr/lib/python3.3/encodings/ascii.py", line 26, in decode
return codecs.ascii_decode(input, self.errors)[0]
UnicodeDecodeError: 'ascii' codec can't decode byte 0xe2 in position 19532: ordinal not in range(128)
make[2]: *** [tests-clar/clar.suite] Error 1
make[1]: *** [CMakeFiles/libgit2_clar.dir/all] Error 2
make: *** [all] Error 2
==> ERROR: A failure occurred in build().
Aborting...

yoseforb commented on 2013-04-16 17:13

And add the provides 'libgit2=0.18.0'

yoseforb commented on 2013-04-16 17:12

Add "-DTHREADSAFE=ON" option for support thread for libgit2-glib (for gitg).

By the way, how can we build the documentation ?

thestinger commented on 2013-04-11 11:50

@eworm: sadly git describe can't be used because their tags are messed up

only 0.16 is an annotated tag and 0.17 never properly ended up in the master branch

eworm commented on 2013-04-11 11:29

I would like to get some enhancements merge into the PKGBUILD. Take a look here: http://codepad.org/ZYKHKHuT

This makes use of pkgver() function to update package version string to git version. Additionally I've added -DTHREADSAFE=ON as this is needed for gitg from git.