Package Details: libfprint-git 1:1.90.3.r15.ge27b65c-1

Git Clone URL: https://aur.archlinux.org/libfprint-git.git (read-only, click to copy)
Package Base: libfprint-git
Description: Library for fingerprint readers
Upstream URL: https://fprint.freedesktop.org/
Keywords: fprint
Licenses: LGPL
Groups: fprint
Conflicts: libfprint
Provides: libfprint=1.90.3.r15.ge27b65c, libfprint-2.so
Submitter: matthewbauer
Maintainer: timothy_gu
Last Packager: timothy_gu
Votes: 29
Popularity: 0.128447
First Submitted: 2009-09-01 02:39
Last Updated: 2020-10-15 06:20

Required by (9)

Sources (1)

Latest Comments

1 2 3 4 5 6 Next › Last »

timothy_gu commented on 2020-01-19 04:39

Alright, I've taken over the maintenance of this package. I use it fairly regularly for my ThinkPad T490s and will try to keep this up to date.

intelfx commented on 2020-01-18 14:38

@timothy_gu: Done. Thanks. I guess I'll just disown this package as I don't own/use compatible hardware anymore and don't have this installed...

timothy_gu commented on 2020-01-18 05:24

The latest version of libfprint requires some additional packages like libgusb. This works for me:

depends=('glib2>=2.56' 'libgusb>=0.3.0' nss pixman)
makedepends=(git gobject-introspection gtk-doc 'meson>=0.49.0')
checkdepends=('umockdev>=0.13.2')

With this you could also enable check() support:

check() {
  meson test -C build
}

Finally, the -D x11-examples=false in build() no longer does anything and can be removed. (Examples are all GTK-based now.)

intelfx commented on 2020-01-02 22:04

@ytexas @otaj Fixed. The official repo PKGBUILD strangely does not include gobject-introspection as a makedep.

ytexas commented on 2019-12-31 05:24

Need: gobject-introspection

Required by meson when compiling.

otaj commented on 2019-11-26 15:31

gobject-introspection is missing from makedepends

rindeal commented on 2018-09-25 23:07

I've developed a new driver for the proprietary binaries, which include support for VFS495 (among others). The source code and installation instructions are here - https://github.com/rindeal/libfprint-vfs_proprietary-driver.

SammysHP commented on 2018-08-14 09:41

@intelfx Yeah, this should be fine now, thanks! I'll delete/move my package libfprint-upstream-git.

intelfx commented on 2018-08-13 20:39

@rocky7x I have since dropped the vfs495-daemon glue patch because it stopped applying and I have found no interest in forward-porting it again.

@SammysHP I believe now you have no concerns over this package?

rocky7x commented on 2018-08-13 13:55

Having VFS495 Validity device (138a:003f) and when I install this together with vfs495-daemon it doesn't work - throws No devices found - any idea? i added myself to plugdev and scanner groups...