Package Details: libfm-git 1.2.2.1.35.gf238b1b-1

Git Clone URL: https://aur.archlinux.org/libfm-git.git (read-only, click to copy)
Package Base: libfm-git
Description: A glib/gio-based library to develop file managers. Does not include the GTK components.
Upstream URL: http://www.lxde.org
Licenses: GPL2
Conflicts: libfm, libfm-extra
Provides: libfm, libfm-extra
Submitter: None
Maintainer: ljmf00
Last Packager: jleclanche
Votes: 119
Popularity: 0.000000
First Submitted: 2009-12-24 04:42
Last Updated: 2015-06-09 12:33

Dependencies (7)

Required by (2)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 ... Next › Last »

cargoan commented on 2013-08-04 05:14

pcmanfm and libfm latest sources from git are in sourceforge, not github.
http://wiki.lxde.org/en/LXDE:PCManFM_build_and_setup_guide#The_latest_source_code_in_development_from_git

url="http://pcmanfm.sourceforge.net/"
source=("git://pcmanfm.git.sourceforge.net/gitroot/pcmanfm/libfm")
source=("git://pcmanfm.git.sourceforge.net/gitroot/pcmanfm/pcmanfm")

cargoan commented on 2013-08-04 05:12

pcmanfm and libfm git latest sources are in sourceforge, not github.
http://wiki.lxde.org/en/LXDE:PCManFM_build_and_setup_guide#The_latest_source_code_in_development_from_git

url="http://pcmanfm.sourceforge.net/"
source=("git://pcmanfm.git.sourceforge.net/gitroot/pcmanfm/libfm")
source=("git://pcmanfm.git.sourceforge.net/gitroot/pcmanfm/pcmanfm")

Alister.Hood commented on 2013-08-03 07:18

The PKGBUILD has udisks in the depends and:
--enable-udisks

jleclanche commented on 2013-08-03 06:14

udisks support is udisks1 only and somewhat broken; so it stays disabled

Alister.Hood commented on 2013-08-03 05:34

Also, does the udisks support actually work for anybody? Last time I checked it didn't work for me, and upstream recommended disabling it as they didn't intend to fix it.

Alister.Hood commented on 2013-08-03 05:32

Yes, please update as described by cargoan.

Diego commented on 2013-07-21 20:00

disowned!
I at this time do not have enough time. For good of the community I've disowned it.

cargoan commented on 2013-07-21 19:54

Now works with automake 1.14

Update makedepends and comment or remove this in build()
### temporary workaround for building failure
sed -i '/_\$(V)/d;/AM_DEFAULT_VERBOSITY/d' gtk-doc.make
sed -i 's,done \\,done ; \\,' gtk-doc.make
autoreconf -fiv

cargoan commented on 2013-07-21 19:52

Now works with automake 1.14

Update makedepends and remove this in build()
### temporary workaround for building failure
sed -i '/_\$(V)/d;/AM_DEFAULT_VERBOSITY/d' gtk-doc.make
sed -i 's,done \\,done ; \\,' gtk-doc.make
autoreconf -fiv

cargoan commented on 2013-07-21 19:29

Now builds with automake 1.4 and fixed gtk-doc.make.
Update makedepends and remove these lines from build():
### temporary workaround for building failure
sed -i '/_\$(V)/d;/AM_DEFAULT_VERBOSITY/d' gtk-doc.make
sed -i 's,done \\,done ; \\,' gtk-doc.make
autoreconf -fiv