Package Details: libcamera-clang-git r2468.8634c386-1

Git Clone URL: https://aur.archlinux.org/libcamera-clang-git.git (read-only, click to copy)
Package Base: libcamera-clang-git
Description: A complex camera support library for Linux, Android, and ChromeOS (built with clang)
Upstream URL: https://libcamera.org/
Licenses: GPL, custom, BSD, LGPL, MIT, Apache
Conflicts: libcamera, libcamera-git
Provides: libcamera, libcamera-git
Submitter: SamLukeYes
Maintainer: SamLukeYes
Last Packager: SamLukeYes
Votes: 0
Popularity: 0.000000
First Submitted: 2021-02-10 07:12
Last Updated: 2021-03-31 07:48

Required by (9)

Sources (1)

Latest Comments

SamLukeYes commented on 2021-03-21 05:35

@A.J The latest PKGBUILD should fix your issue.

A.J commented on 2021-03-17 21:47

it's failing to install with this error :


FAILED: src/gstreamer/libgstlibcamera.so.p/gstlibcamerasrc.cpp.o 
clang++ -Isrc/gstreamer/libgstlibcamera.so.p -Isrc/gstreamer -I../src/gstreamer -Iinclude -I../include -Iinclude/libcamera -I/usr/include/gstreamer-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/orc-0.4 -Xclang -fcolor-diagnostics -pipe -D_FILE_OFFSET_BITS=64 -Wall -Winvalid-pch -Wnon-virtual-dtor -Wextra -Werror -std=c++17 -g -stdlib=libc++ -Wextra-semi -Wshadow -include config.h -Wno-c99-designator -march=x86-64 -mtune=generic -O2 -fno-plt -D_FORTIFY_SOURCE=2 -fPIC -pthread '-DVERSION="0.0.0+2409-79b48225"' '-DPACKAGE="libcamera"' -MD -MQ src/gstreamer/libgstlibcamera.so.p/gstlibcamerasrc.cpp.o -MF src/gstreamer/libgstlibcamera.so.p/gstlibcamerasrc.cpp.o.d -o src/gstreamer/libgstlibcamera.so.p/gstlibcamerasrc.cpp.o -c ../src/gstreamer/gstlibcamerasrc.cpp
In file included from ../src/gstreamer/gstlibcamerasrc.cpp:39:
In file included from /usr/include/gstreamer-1.0/gst/base/base.h:35:
/usr/include/gstreamer-1.0/gst/base/gstbytereader.h:365:21: error: 'g_memdup' is deprecated: Use 'g_memdup2' instead [-Werror,-Wdeprecated-declarations]
  return (guint8 *) g_memdup (data, size);
                    ^
/usr/include/glib-2.0/glib/gstrfuncs.h:256:1: note: 'g_memdup' has been explicitly marked deprecated here
GLIB_DEPRECATED_IN_2_68_FOR (g_memdup2)
^
/usr/include/glib-2.0/glib/gversionmacros.h:1047:49: note: expanded from macro 'GLIB_DEPRECATED_IN_2_68_FOR'
# define GLIB_DEPRECATED_IN_2_68_FOR(f)         GLIB_DEPRECATED_FOR(f)
                                                ^
/usr/include/glib-2.0/glib/gmacros.h:1072:32: note: expanded from macro 'GLIB_DEPRECATED_FOR'
#define GLIB_DEPRECATED_FOR(f) G_DEPRECATED_FOR(f) _GLIB_EXTERN
                               ^
/usr/include/glib-2.0/glib/gmacros.h:1040:44: note: expanded from macro 'G_DEPRECATED_FOR'
#define G_DEPRECATED_FOR(f) __attribute__((__deprecated__("Use '" #f "' instead")))
                                           ^
1 error generated.
[163/302] Compiling C++ object src/qcam/qcam.p/main_window.cpp.o
ninja: build stopped: subcommand failed.
==> ERROR: A failure occurred in build().
    Aborting...
error: target not found: libcamera-clang-git