Package Details: libadwaita-shortwave 1:r1937.afee036-2

Git Clone URL: https://aur.archlinux.org/libadwaita-shortwave.git (read-only, click to copy)
Package Base: libadwaita-shortwave
Description: Library full of GTK widgets for mobile phones (version required by shortwave)
Upstream URL: https://gitlab.gnome.org/GNOME/libadwaita
Licenses: LGPL
Conflicts: libadwaita
Provides: libadwaita
Submitter: billypilgrim
Maintainer: billypilgrim
Last Packager: billypilgrim
Votes: 1
Popularity: 0.42
First Submitted: 2021-06-09 19:02
Last Updated: 2021-06-25 11:28

Required by (27)

Sources (1)

Latest Comments

billypilgrim commented on 2021-06-25 12:09

@mabod I've done that now :-)

mabod commented on 2021-06-25 11:38

@billypilgrim: I guess you best discuss this with the developer in the issue I have created. He also claims that yay and paru behave the same and have the same problem. He says: "Yay and paru both have the exact same handling of -git packages. Which they think libadwaita-shortwave is because of the unversioned source."

billypilgrim commented on 2021-06-25 11:16

I don't mind changing the PKGBUILD, though I still think this is silly behaviour on paru's part. And who wants a package that's updated every time upstream pushes to the master branch anyway?!

billypilgrim commented on 2021-06-24 07:46

My point is that libadwaita-shortwave isn't a *-git package. It's a package which has a git repo as a source, but it always uses the same version (because if you use a different version of libadwaita it breaks shortwave). So if paru thinks there is a new version available, then it's wrong.

I'm using yay and it doesn't try to upgrade libadwaita-shortwave ever. Have you changed a config option or something?

mabod commented on 2021-06-24 05:16

This is not an explanation I can follow. I have other *.git packages which work just fine, like:

dnscomp-git 0.r28.bbcea7c-1 glances-git 3.1.7.r99.g2207e9be-1 it87-dkms-git 154.b159857-1 ...

And yay is doing the same thing, always asking to reinstall libadwaita-shortwave-1:r1937.afee036-1

billypilgrim commented on 2021-06-23 21:31

Then it's presumably a bug in paru. I'm guessing that because there is a git repo in the sources array, paru assumes that you want to update the package whenever there are changes to the git repo, which you definitely don't want for this package as it's deliberately pegged to a specific git commit. Frankly I think that's pretty dubious behaviour in the case where you actually are using a *-git version of a package because users really should be left to update it as and when they want, but it's definitely broken in this case.

mabod commented on 2021-06-23 21:26

I am using paru.

billypilgrim commented on 2021-06-23 17:18

What program are you using to manage your package updates? Pamac or something?

mabod commented on 2021-06-23 16:30

libadwaita-shortwave-1:r1937.afee036-1 wants to be installed several times a day. It keeps on showing up and repeatedly asks for installation. Why is that?