Package Details: lib32-zbar 0.23-1

Git Clone URL: https://aur.archlinux.org/lib32-zbar.git (read-only, click to copy)
Package Base: lib32-zbar
Description: Application and library for reading bar codes from various sources. 32bit libraries only version
Upstream URL: https://github.com/procxx/zbar
Licenses: LGPL
Submitter: llde
Maintainer: llde
Last Packager: llde
Votes: 3
Popularity: 0.68
First Submitted: 2017-08-24 18:36
Last Updated: 2019-11-28 22:04

Latest Comments

1 2 Next › Last »

llde commented on 2019-11-28 21:33

Currently trying to fix the reported issue in this and lib32-lv2

Expect an update ASAP

DDoSolitary commented on 2019-11-12 08:11

Hello, they're several problems with the dependencies of this package, which are preventing it to build/run on a clean environment.

  • lib32-imagemagick, lib32-libxv, lib32-v4l-utils should be in depends instead of makedepends because their so files are required at runtime.
  • Missing dependency lib32-dbus
  • Missing dependency docbook-xsl
  • There's no need to include lib32-gtk2 and pygtk because gtk features have been disabled when configuring (--without-gtk)

tjackson commented on 2019-10-19 17:26

docbook-xsl seems to be a makedepend.

travelskid commented on 2019-06-02 16:52

same problem as @Nocifer with 0.22 ... but i can't find a downgraded version

petter3k commented on 2019-05-05 08:39

Same problem as @Nocifer with both Oracle JDK 12 and OpenJDK 8.

Had to downgrade to 0.20.

llde commented on 2019-04-08 10:02

@Nocifer I don't know what caused the error but it seem unluckly that that warning will cause any error during compilation.

However I uploaded 0.22 syncing with arch repos, you may try that

Nocifer commented on 2019-02-23 09:48

I've been getting this error with 0.21:

...
make[2]: Leaving directory '/home/nocifer/.cache/yay/lib32-zbar/src/zbar-0.21'
Making all in java
make[2]: Entering directory '/home/nocifer/.cache/yay/lib32-zbar/src/zbar-0.21/java'
cd /home/nocifer/.cache/yay/lib32-zbar/src/zbar-0.21/java; /usr/bin/javac -d /home/nocifer/.cache/yay/lib32-zbar/src/zbar-0.21/java net/sourceforge/zbar/Config.java net/sourceforge/zbar/Modifier.java net/sourceforge/zbar/Orientation.java net/sourceforge/zbar/Symbol.java net/sourceforge/zbar/SymbolIterator.java net/sourceforge/zbar/SymbolSet.java net/sourceforge/zbar/Image.java net/sourceforge/zbar/ImageScanner.java
Note: Some input files use or override a deprecated API.
Note: Recompile with -Xlint:deprecation for details.
/usr/bin/jar cf zbar.jar net/sourceforge/zbar/Config.class net/sourceforge/zbar/Modifier.class net/sourceforge/zbar/Orientation.class net/sourceforge/zbar/Symbol.class net/sourceforge/zbar/SymbolIterator.class net/sourceforge/zbar/SymbolSet.class net/sourceforge/zbar/Image.class net/sourceforge/zbar/ImageScanner.class || rm -f zbar.jar
classes=`echo net/sourceforge/zbar/Config net/sourceforge/zbar/Modifier net/sourceforge/zbar/Orientation net/sourceforge/zbar/Symbol net/sourceforge/zbar/SymbolIterator net/sourceforge/zbar/SymbolSet net/sourceforge/zbar/Image net/sourceforge/zbar/ImageScanner | tr / .` ; \
        /bin/false -o zbarjni.h $classes
make[2]: *** [Makefile:783: zbarjni.h] Error 1
make[2]: Leaving directory '/home/nocifer/.cache/yay/lib32-zbar/src/zbar-0.21/java'
make[1]: *** [Makefile:2674: all-recursive] Error 1
make[1]: Leaving directory '/home/nocifer/.cache/yay/lib32-zbar/src/zbar-0.21'
make: *** [Makefile:1199: all] Error 2
==> ERROR: A failure occurred in build().
    Aborting...
Error making: lib32-zbar

Just tried to rebuild 0.20 and it built successfully under the same environment. So... what gives?

staeffn commented on 2018-09-29 13:24

@DarkShadow44 Thanks, with a downgraded version it works!

Do I have to keep lib32-v4l-utils on that version for now? or is it safe to go back to the up-to-date version once it's installed?

DarkShadow44 commented on 2018-09-29 13:12

@staeffn Confirming the issue. Problem is logged in the config.log: /usr/bin/ld: /usr/lib32/libv4lconvert.so.0: undefined reference tominor'`

Downgrading lib32-v4l-utils (1.14.2-1 => 1.12.5-1) helps.

staeffn commented on 2018-09-29 12:51

Hello, I'm running into the following error:

configure: error: unable to find libv4l.so

when i check /usr/lib i really don't have it, only have libv4l1.so - tried to just add a symlink, but without any luck (might be utter nonsense anyways, just the only thing that came to mind for me). I'm kinda unexperienced so I guess I'm missing something here, do i have to do anything else but ln -s /usr/lib/libv4l1.so.0.0.0 /usr/lib/libv4l.so ? Anything else entirely? I have all the dependencies installed. Any help/hints are much appreciated!