Package Details: lib32-tclkit 8.6.6-3

Git Clone URL: https://aur.archlinux.org/lib32-tclkit.git (read-only, click to copy)
Package Base: lib32-tclkit
Description: single-file executable that provides a complete Tcl and Tk runtime (32 bits version)
Upstream URL: https://github.com/patthoyts/kitgen
Licenses: custom
Conflicts: tclkit
Provides: tclkit
Submitter: mickael9
Maintainer: mickael9 (greyltc)
Last Packager: mickael9
Votes: 9
Popularity: 0.000013
First Submitted: 2015-08-04 18:58
Last Updated: 2018-06-26 17:45

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

calcmogul commented on 2017-06-08 06:55

Downgrading libpng to 1.6.28 sidesteps the issue. Old versions are available at https://archive.archlinux.org/packages/l/libpng/.

syther commented on 2017-03-29 23:25

Heres an error I keep getting.


/usr/lib32/libpng16.so.16: undefined reference to `inflateValidate@ZLIB_1.2.9'
collect2: error: ld returned 1 exit status
make[1]: *** [Makefile:618: wish] Error 1
make[1]: Leaving directory '/tmp/yaourt-tmp-syther/aur-lib32-tclkit/src/kitgen-c21eeb1e379bd5acb5b304f0784877b8e8dd31ca/8.6/kit-large/build/tkdyn'
make: *** [../../makefile.include:83: build/tkdyn] Error 2
make: Leaving directory '/tmp/yaourt-tmp-syther/aur-lib32-tclkit/src/kitgen-c21eeb1e379bd5acb5b304f0784877b8e8dd31ca/8.6/kit-large'
==> ERROR: A failure occurred in build().
Aborting...

vinadoros commented on 2016-08-12 18:15

To further clarify the out-of-date flag, the new md5sums are:
38666636f5531acbeb6c669808249625 ./tk.tar.gz
a7bf7b9bcaea80e91c471f233ddc445d ./tcl.tar.gz

Alad commented on 2016-03-27 00:22

==> Starting build()...
Configuring 8.6/kit-large/Makefile for Linux.
make: Entering directory '/home/aur/lib32-tclkit/src/kitgen-c21eeb1e379bd5acb5b304f0784877b8e8dd31ca/8.6/kit-large'
mkdir -p build/tcl && cd build/tcl && CFLAGS="-m32 -O2" && export CFLAGS && \
sh ../../../tcl/unix/configure --disable-shared --enable-threads \
--prefix=/home/aur/lib32-tclkit/src/kitgen-c21eeb1e379bd5acb5b304f0784877b8e8dd31ca/8.6/kit-large/build --exec-prefix=/home/aur/lib32-tclkit/src/kitgen-c21eeb1e379bd5acb5b304f0784877b8e8dd31ca/8.6/kit-large/build && \
make install-binaries install-libraries install-headers install-private-headers
sh: 0: Can't open ../../../tcl/unix/configure
../../makefile.include:60: recipe for target 'build/tcl' failed
make: *** [build/tcl] Error 127
make: Leaving directory '/home/aur/lib32-tclkit/src/kitgen-c21eeb1e379bd5acb5b304f0784877b8e8dd31ca/8.6/kit-large'

Alad commented on 2016-03-26 23:58

:: Checking lib32-tclkit integrity...
==> Making package: lib32-tclkit 8.6.4-4 (So 27. Mär 00:53:57 CET 2016)
==> Retrieving sources...
-> Found tclkit.tar.gz
-> Found tk.tar.gz
-> Found tcl.tar.gz
-> Found kitgen-cflags-quoting.patch
==> Validating source files with md5sums...
tclkit.tar.gz ... Passed
tk.tar.gz ... Passed
tcl.tar.gz ... FAILED
kitgen-cflags-quoting.patch ... Passed
==> ERROR: One or more files did not pass the validity check!

greyltc commented on 2016-01-19 15:33

great. thanks!

mickael9 commented on 2016-01-19 15:30

@evana: thanks, I added the ucl dependency to makedepends

@greyltc : since you maintain tclkit, I added you as a co-maintainer for this one. That way you can apply changes to both packages if needed

doragasu commented on 2016-01-19 08:15

I can confirm @evana's comment: package is missing ucl depend.

evana commented on 2016-01-08 21:14

Package needs to depend on ucl as well. It would not build without it.

mnivoliez commented on 2016-01-06 13:56

The md5sum for tcl and tk are false,
here the good ones:
tk: 217158b34ce82baf8f9aaf5f9e584ad2
tcl: a6485fca8f4ca5314a9dcb1c8c8eaca0