Package Details: lib32-sane 1.0.30-1

Git Clone URL: https://aur.archlinux.org/lib32-sane.git (read-only, click to copy)
Package Base: lib32-sane
Description: Scanner Access Now Easy (32 bit)
Upstream URL: http://www.sane-project.org/
Licenses: GPL
Submitter: mirh
Maintainer: None
Last Packager: mirh
Votes: 1
Popularity: 0.38
First Submitted: 2020-03-27 14:54
Last Updated: 2020-05-26 11:42

Latest Comments

1 2 Next › Last »

Leion commented on 2020-09-16 01:23

~  yay -S lib32-sane            
:: Checking for conflicts...
:: Checking for inner conflicts...
[Repo:6]  lib32-libwebp-1.1.0-1  lib32-libusb-1.0.23-1  lib32-gdbm-1.12-1  lib32-libdaemon-0.14-6  lib32-libnl-3.5.0-1  lib32-kmod-22-1
[Repo Make:43]  xorg-util-macros-1.19.2-2  autoconf-archive-1:2019.01.06-2  python-markupsafe-1.1.1-4  python-beaker-1.11.0-4  python-mako-1.1.3-1  python-markdown-3.2.2-1  gobject-introspection-1.64.1-2  libgdiplus-5.6.1-3  mono-6.10.0.104-1  gtk-sharp-2-2.12.45-2  intltool-0.51.0-6  lib32-atk-2.36.0-1  lib32-libdatrie-0.2.12-1  lib32-libthai-0.1.28-1  lib32-pixman-0.40.0-1  lib32-cairo-1.17.2+25+gaee96d175-1  lib32-libxft-2.3.3-1  lib32-fribidi-1.0.10-1  lib32-pango-1:1.46.1-1  lib32-gdk-pixbuf2-2.40.0+6+g5432316df-1  lib32-gtk2-2.24.32-2  lib32-at-spi2-core-2.36.0-1  lib32-at-spi2-atk-2.34.2-1  lib32-dconf-0.36.0-1  lib32-libgudev-233-1  lib32-libgusb-0.3.5-1  lib32-libtirpc-1.2.6-1  lib32-libnsl-1.3.0-1  lib32-pam-1.4.0-1  lib32-polkit-0.117-1  lib32-colord-1.4.4-1  lib32-json-glib-1.4.4-1  lib32-libepoxy-1.5.4-1  lib32-librsvg-2.48.8-1  lib32-libxkbcommon-0.10.0-1  lib32-brotli-1.0.7-1  lib32-libproxy-0.4.15-2  lib32-glib-networking-2.64.3-1  lib32-libpsl-0.21.1-1  lib32-libsoup-2.70.0-1  lib32-rest-0.8.1-2  lib32-gtk3-3.24.22-1  xmltoman-0.4-4
[Aur:9]  lib32-libexif-0.6.21-4  lib32-libxpm-3.5.13-2  lib32-gd-2.2.5-2  lib32-libgphoto2-2.5.25-1  lib32-libieee1284-0.2.11-6  lib32-avahi-0.7+18+g1b5f401-1  lib32-pciutils-3.6.4-1  lib32-net-snmp-5.8-2  lib32-sane-1.0.30-1

==> Remove make dependencies after install? [y/N] 
  9 lib32-libexif                    (Build Files Exist)
  8 lib32-libxpm                     (Build Files Exist)
  7 lib32-gd                         (Build Files Exist)
  6 lib32-libgphoto2                 (Build Files Exist)
  5 lib32-libieee1284                (Build Files Exist)
  4 lib32-avahi                      (Build Files Exist)
  3 lib32-pciutils                   (Build Files Exist)
  2 lib32-net-snmp                   (Build Files Exist)
  1 lib32-sane                       (Build Files Exist)
==> Packages to cleanBuild?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> 
:: PKGBUILD up to date, Skipping (1/9): lib32-libgphoto2
:: PKGBUILD up to date, Skipping (2/9): lib32-sane
:: PKGBUILD up to date, Skipping (3/9): lib32-libieee1284
:: PKGBUILD up to date, Skipping (4/9): lib32-avahi
:: PKGBUILD up to date, Skipping (5/9): lib32-pciutils
:: PKGBUILD up to date, Skipping (6/9): lib32-libxpm
:: PKGBUILD up to date, Skipping (7/9): lib32-net-snmp
:: PKGBUILD up to date, Skipping (8/9): lib32-libexif
:: PKGBUILD up to date, Skipping (9/9): lib32-gd
  9 lib32-libexif                    (Build Files Exist)
  8 lib32-libxpm                     (Build Files Exist)
  7 lib32-gd                         (Build Files Exist)
  6 lib32-libgphoto2                 (Build Files Exist)
  5 lib32-libieee1284                (Build Files Exist)
  4 lib32-avahi                      (Build Files Exist)
  3 lib32-pciutils                   (Build Files Exist)
  2 lib32-net-snmp                   (Build Files Exist)
  1 lib32-sane                       (Build Files Exist)
==> Diffs to show?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> 
:: (1/9) Parsing SRCINFO: lib32-libexif
:: (2/9) Parsing SRCINFO: lib32-libxpm
:: (3/9) Parsing SRCINFO: lib32-gd
:: (4/9) Parsing SRCINFO: lib32-libgphoto2
:: (5/9) Parsing SRCINFO: lib32-libieee1284
:: (6/9) Parsing SRCINFO: lib32-avahi
:: (7/9) Parsing SRCINFO: lib32-pciutils
:: (8/9) Parsing SRCINFO: lib32-net-snmp
:: (9/9) Parsing SRCINFO: lib32-sane

:: PGP keys need importing:
 -> 8AAA779B597B405BBC329B6376CF47B8A77C5329, required by: lib32-net-snmp
 -> 27CAA4A32E371383A33ED0587D5F9576E0F81533, required by: lib32-net-snmp
 -> D0F8F495DA6160C44EFFBF10F07B9D2DACB19FD6, required by: lib32-net-snmp
 -> 7C4AFD61D8AAE7570796A5172209D6902F969C95, required by: lib32-libgphoto2
 -> 5558F9399CD7836850553C6EC28E7847ED70F82D, required by: lib32-pciutils
==> Import? [Y/n] 
:: Importing keys with gpg...
gpg: 从公钥服务器接收失败:一般错误
problem importing keys

pulsar-nerd commented on 2020-08-10 13:58

I am getting error. Please update the package.

==> PGP keys need importing:
 -> D0F8F495DA6160C44EFFBF10F07B9D2DACB19FD6, required by: lib32-net-snmp
 -> 7C4AFD61D8AAE7570796A5172209D6902F969C95, required by: lib32-libgphoto2
 -> 5558F9399CD7836850553C6EC28E7847ED70F82D, required by: lib32-pciutils
 -> 8AAA779B597B405BBC329B6376CF47B8A77C5329, required by: lib32-net-snmp
 -> 27CAA4A32E371383A33ED0587D5F9576E0F81533, required by: lib32-net-snmp
==> Import? [Y/n] y
:: Importing keys with gpg...
gpg: keyserver receive failed: General error
error: target not found: xorg-util-macros
error: target not found: autoconf-archive
error: target not found: python-markupsafe
error: target not found: python-beaker
error: target not found: python-mako
error: target not found: python-markdown
error: target not found: gobject-introspection
error: target not found: libgdiplus
error: target not found: mono
error: target not found: libglade
error: target not found: gtk-sharp-2
error: target not found: intltool
error: target not found: lib32-atk
error: target not found: lib32-libdatrie
error: target not found: lib32-libthai
error: target not found: lib32-pixman
error: target not found: lib32-cairo
error: target not found: lib32-libxft
error: target not found: lib32-fribidi
error: target not found: lib32-pango
error: target not found: lib32-gdk-pixbuf2
error: target not found: lib32-gtk2
error: target not found: lib32-at-spi2-core
error: target not found: lib32-at-spi2-atk
error: target not found: lib32-dconf
error: target not found: lib32-libgudev
error: target not found: lib32-libgusb
error: target not found: lib32-cracklib
error: target not found: lib32-libtirpc
error: target not found: lib32-libnsl
error: target not found: lib32-pam
error: target not found: lib32-polkit
error: target not found: lib32-sqlite
error: target not found: lib32-colord
error: target not found: lib32-json-glib
error: target not found: lib32-libepoxy
error: target not found: lib32-librsvg
error: target not found: lib32-libxkbcommon
error: target not found: lib32-brotli
error: target not found: lib32-libproxy
error: target not found: lib32-glib-networking
error: target not found: lib32-libpsl
error: target not found: lib32-libsoup
error: target not found: lib32-rest
error: target not found: lib32-gtk3
error: target not found: python2-cairo
error: target not found: pygtk
error: target not found: xmltoman

sramey40 commented on 2020-07-31 20:58

Can't install package due to not being able to import keys. Anybody know what to do?

:: (1/12) Parsing SRCINFO: lib32-libexif

:: (2/12) Parsing SRCINFO: lib32-libxpm

:: (3/12) Parsing SRCINFO: lib32-gd

:: (4/12) Parsing SRCINFO: lib32-libgphoto2

:: (5/12) Parsing SRCINFO: lib32-libieee1284

:: (6/12) Parsing SRCINFO: lib32-gdbm

:: (7/12) Parsing SRCINFO: pygtk

:: (8/12) Parsing SRCINFO: lib32-avahi

:: (9/12) Parsing SRCINFO: lib32-kmod

:: (10/12) Parsing SRCINFO: lib32-pciutils

:: (11/12) Parsing SRCINFO: lib32-net-snmp

:: (12/12) Parsing SRCINFO: lib32-sane

:: PGP keys need importing:

-> 7C4AFD61D8AAE7570796A5172209D6902F969C95, required by: lib32-libgphoto2

-> 5558F9399CD7836850553C6EC28E7847ED70F82D, required by: lib32-pciutils

-> 8AAA779B597B405BBC329B6376CF47B8A77C5329, required by: lib32-net-snmp

-> 27CAA4A32E371383A33ED0587D5F9576E0F81533, required by: lib32-net-snmp

-> D0F8F495DA6160C44EFFBF10F07B9D2DACB19FD6, required by: lib32-net-snmp

==> Import? [Y/n] y

:: Importing keys with gpg...

gpg: keyserver receive failed: General error

[sudo] password for sean:

error: target not found: pygtk

error: target not found: autoconf-archive

error: target not found: libgdiplus

error: target not found: mono

error: target not found: libglade

error: target not found: gtk-sharp-2

error: target not found: perl-encode-locale

error: target not found: perl-http-date

error: target not found: perl-file-listing

error: target not found: perl-html-tagset

error: target not found: perl-html-parser

error: target not found: perl-clone

error: target not found: perl-io-html

error: target not found: perl-lwp-mediatypes

error: target not found: perl-uri

error: target not found: perl-http-message

error: target not found: perl-http-cookies

error: target not found: perl-http-daemon

error: target not found: perl-http-negotiate

error: target not found: perl-net-http

error: target not found: perl-try-tiny

error: target not found: perl-www-robotrules

error: target not found: perl-libwww

error: target not found: perl-xml-parser

error: target not found: intltool

error: target not found: python2-cairo

error: target not found: python2-gobject2

error: target not found: python2-numpy

error: target not found: xmltoman

error: target not found: python2-appdirs

error: target not found: python2-pyparsing

error: target not found: python2-six

error: target not found: python2-packaging

error: target not found: python2-ordered-set

error: target not found: python2-setuptools

Peredo commented on 2020-07-18 22:33

Two things you need to do in order to install this package:

1- Change gdbm code

a) Use this patch: https://705898.bugs.gentoo.org/attachment.cgi?id=603950 b) or manually edit parseopt.c file by adding extern in front of the following lines: char parseopt_program_doc; and char parseopt_program_args;

2- lib32-curl is also a dependency

sl1pkn07 commented on 2020-06-20 14:03

build ok without avahi

mirh commented on 2020-05-26 11:43

At least with gcc 9 it worked fine.. Anyway, new updated version may be better now.

mattf commented on 2020-05-23 22:24

And after I manually added the key, I have the compile error:

CC util.o CC input-rl.o CCLD gdbmtool /usr/bin/ld: ./libgdbmapp.a(parseopt.o):(.bss+0x4): multiple definition of parseopt_program_args'; gdbmtool.o:(.data.rel.local+0x150): first defined here /usr/bin/ld: ./libgdbmapp.a(parseopt.o):(.bss+0x8): multiple definition ofparseopt_program_doc'; gdbmtool.o:(.data.rel.local+0x154): first defined here collect2: error: ld returned 1 exit status make[3]: [Makefile:656: gdbmtool] Error 1 make[3]: Leaving directory '/tmp/yaourt-tmp-matheus/aur-lib32-gdbm/src/gdbm-1.18.1/src' make[2]: [Makefile:499: all] Error 2 make[2]: Leaving directory '/tmp/yaourt-tmp-matheus/aur-lib32-gdbm/src/gdbm-1.18.1/src' make[1]: [Makefile:464: all-recursive] Error 1 make[1]: Leaving directory '/tmp/yaourt-tmp-matheus/aur-lib32-gdbm/src/gdbm-1.18.1' make: [Makefile:396: all] Error 2

mattf commented on 2020-05-23 22:10

I have this pgp signature problem:

-> Downloading kmod-25.tar.sign... % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed 100 162 100 162 0 0 79 0 0:00:02 0:00:02 --:--:-- 79 100 801 100 801 0 0 226 0 0:00:03 0:00:03 --:--:-- 1181 ==> Validating source files with md5sums... kmod-25.tar.xz ... Passed kmod-25.tar.sign ... Skipped ==> Verifying source file signatures with gpg... kmod-25.tar ... FAILED (unknown public key 9BA2A5A630CBEA53) ==> ERROR: One or more PGP signatures could not be verified! Error downloading sources: lib32-kmod

freenestor commented on 2020-05-13 04:56

solved after installing lib32-curl

freenestor commented on 2020-05-13 03:46

compile error, how to fix it?

/usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-pc-linux-gnu/9.3.0/../../../libcurl.so when searching for -lcurl /usr/bin/ld: skipping incompatible /usr/lib/libcurl.so when searching for -lcurl /usr/bin/ld: cannot find -lcurl collect2: error: ld returned 1 exit status make[2]: [Makefile:3804: libsane-escl.la] Error 1 make[2]: Waiting for unfinished jobs.... ar: u' modifier ignored sinceD' is the default (see `U') make[2]: Leaving directory '/tmp/yaourt-tmp-aart/aur-lib32-sane/src/sane-backends-1.0.29/backend' make[1]: [Makefile:3275: all] Error 2 make[1]: Leaving directory '/tmp/yaourt-tmp-aart/aur-lib32-sane/src/sane-backends-1.0.29/backend' make: [Makefile:597: all-recursive] Error 1