Package Details: lib32-nvidia-utils-full-beta 440.26-1

Git Clone URL: https://aur.archlinux.org/nvidia-full-beta.git (read-only)
Package Base: nvidia-full-beta
Description: NVIDIA driver utilities and libraries for 'nvidia-full-beta' (32-bit)
Upstream URL: https://www.nvidia.com/
Keywords: lib32-opencl-driver lib32-vulkan-driver libglvnd nvidia-settings opencl-driver vulkan-driver
Licenses: custom
Conflicts: lib32-nvidia-libgl, lib32-nvidia-utils
Provides: lib32-nvidia-libgl=440.26, lib32-nvidia-libgl-beta=440.26, lib32-nvidia-utils=440.26, lib32-opengl-driver, lib32-vulkan-driver
Replaces: lib32-nvidia-libgl
Submitter: Det
Maintainer: dbermond
Last Packager: dbermond
Votes: 18
Popularity: 0.000522
First Submitted: 2013-06-27 12:48
Last Updated: 2019-10-18 11:03

Required by (10)

Sources (5)

Latest Comments

1 2 3 4 5 6 ... Next › Last »

dbermond commented on 2019-08-30 15:18

@cristatus I'm not disabling PrimaryGPU option by default for now, at least while there is no corresponding change on the repository package.

Up to the users to manually disable it for prime offloading at this moment if needed.

cristatus commented on 2019-08-18 07:12

Apply this patch to enable nvidia offloading.

diff --git a/PKGBUILD b/PKGBUILD
index 3a1744b..2cdafbd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,7 +23,7 @@ source=("https://us.download.nvidia.com/XFree86/Linux-${CARCH}/${pkgver}/${_pkg}
         'FS62142.patch'
         'nvidia-settings-full-beta-change-desktop-paths.patch')
 sha256sums=('a71cecb5b8f0af35ed9a2d4023652a0537271457ef570c5f21dccd5067d9e9a6'
-            '089d6dc247c9091b320c418b0d91ae6adda65e170934d178cdd4e9bd0785b182'
+            'db34474a8ff0baf29116addb5120846b301b8c962f5d604eb5f43229e32a5f22'
             'd8d1caa5d72c71c6430c2a0d9ce1a674787e9272ccce28b9d5898ca24e60a167'
             'c961006882afb691410c017c239e2c2ef61badb88f15735d37112b513ef0a99d'
             '633bf69c39b8f35d0e64062eb0365c9427c2191583f2daa20b14e51772e8423a')
diff --git a/nvidia-drm-outputclass.conf b/nvidia-drm-outputclass.conf
index dd2936c..4b0def1 100644
--- a/nvidia-drm-outputclass.conf
+++ b/nvidia-drm-outputclass.conf
@@ -1,3 +1,8 @@
+Section "ServerLayout"
+   Identifier "layout"
+   Option "AllowNVIDIAGPUScreens"
+EndSection
+
 Section "OutputClass"
     Identifier "intel"
     MatchDriver "i915"
@@ -9,7 +14,6 @@ Section "OutputClass"
     MatchDriver "nvidia-drm"
     Driver "nvidia"
     Option "AllowEmptyInitialConfiguration"
-    Option "PrimaryGPU" "yes"
     ModulePath "/usr/lib/nvidia/xorg"
     ModulePath "/usr/lib/xorg/modules"
 EndSection

dbermond commented on 2019-06-09 03:20

  • Important note:

Package nvidia-egl-wayland-full-beta was dropped since version 430.14-2.

After updating, replace it with egl-wayland from the official repositories with: pacman -Syu egl-wayland

Det commented on 2018-09-20 17:27

Farewell: https://aur.archlinux.org/packages/nvidia-beta/

Det commented on 2018-08-25 16:29

Can't repro. You probably hadn't updated your kernel.

Escorpio commented on 2018-08-25 13:59

cat: /usr/lib/modules/extramodules-ARCH/version: No such file or directory

I get this error. What's weird, there's no problem with "nvidia-beta" package.

Det commented on 2018-04-29 15:56

Different operating system.

The Linux kernel breaks compatibility on the kernel level with each new kernel release, because otherwise you'd be bottlenecked on what you could change in the code.

You rebuild drivers yourself on 4.16 -> 4.17, or update the prebuilt ones provided by your distribution.

linus.cl commented on 2018-04-29 15:55

@wyre: It needs to be rebuild everytime I upgrade the kernel WTTFF.. This is bad. Any fix?

wyre commented on 2018-04-20 13:39

@Det, I'm ArchLinux user, I'm just learning about AUR usage ;-)

Det commented on 2018-04-20 13:14

Yeah. That is also standard AUR knowledge, which I won't be separately specifying for distributions not meant to use this repository.