Package Details: lib32-ncurses5-compat-libs 6.2-1

Git Clone URL: https://aur.archlinux.org/lib32-ncurses5-compat-libs.git (read-only, click to copy)
Package Base: lib32-ncurses5-compat-libs
Description: System V Release 4.0 curses emulation library (32-bit), ABI 5
Upstream URL: https://www.gnu.org/software/ncurses/
Licenses: MIT
Submitter: lpapp
Maintainer: Corax
Last Packager: Corax
Votes: 100
Popularity: 1.14
First Submitted: 2015-09-22 11:38
Last Updated: 2020-04-26 15:55

Pinned Comments

Corax commented on 2019-06-10 18:11

Make sure you have the multilib-devel group installed before reporting issues while building the package. I will not add it as a makedepends because it is not a makedepends for lib32-ncurses5 either. See https://wiki.archlinux.org/index.php/Makepkg#Build_32-bit_packages_on_a_64-bit_system

Corax commented on 2016-08-19 23:33

If anyone is still having trouble getting used to PGP signing, make sure to add the key mentioned in the PKGBUILD:
$ gpg --keyserver pool.sks-keyservers.net --recv-keys 702353E0F7E48EDB

Latest Comments

1 2 3 4 5 6 ... Next › Last »

Corax commented on 2020-05-25 16:02

@heller390: right, if programs compiled with gcc -m32 cannot be run, then I'm not sure how this package is going to be useful to you ;) It looks like WSL1 has no 32-bit support, but WSL2 does, see: https://superuser.com/a/1407818 . Either way I'm not a WSL user so I can't help you much here.

heller390 commented on 2020-05-25 12:37

@Corax programs compiled with gcc32 are not running.They are giving exec format error. I couldn't find the dir for src/ncurses-6.2/config.log. Could you point out the exact path?

Corax commented on 2020-05-25 11:02

@heller390: see what I recommended duff to try below. It would also be useful if you uploaded src/ncurses-6.2/config.log somewhere.

heller390 commented on 2020-05-25 05:26

Having issue building this package on Arch WSL via yay helper and even manually via makepkg. Installed multilib-devel and lib32-gcc-libs. Plz help

https://del.dog/mecoppygha.go

Corax commented on 2020-01-16 23:27

@duff: no problem, glad you got it sorted! AUR wrappers can be a real pain sometimes...

duff commented on 2020-01-16 14:41

@Corax gcc -m32 compiled without an issue.

I found the problem: rua (my AUR wrapper) - for any reason it does not handle the PKGBUILD like it should. I will look into that and maybe report a bug at the right place.

so your PKGBUILD seems to be just fine. Sorry!

Corax commented on 2020-01-11 20:55

@duff: that is strange, no issue on my side. Could you check that gcc -m32 is working, for instance using:

$ gcc -m32 -x c - <<EOF
#include <stdio.h>

int main() { puts("hi"); }
EOF

Also I would suggest trying to build this package using makepkg directly instead of an AUR wrapper.

duff commented on 2020-01-11 13:38

Have problem with building this package on my 64 bit machine. lib32-gcc-libs and multilib-devel were installed multiple times! makepkg.conf is default, btw. whole system is fresh and up to date. This really confuses me...

https://pastebin.com/Ftw6XAuH

Maybe there is a buildflag missing in latest PKGBUILD? I get "checking target system type... x86_64-pc-linux-gnu"

Hope for your answer to get this running asap

Kind regards

Corax commented on 2019-06-10 18:11

Make sure you have the multilib-devel group installed before reporting issues while building the package. I will not add it as a makedepends because it is not a makedepends for lib32-ncurses5 either. See https://wiki.archlinux.org/index.php/Makepkg#Build_32-bit_packages_on_a_64-bit_system

Corax commented on 2019-06-10 18:07

@mrtnster: see https://aur.archlinux.org/packages/lib32-ncurses5-compat-libs/#comment-678446, looks like I need to add a pinned comment...