Package Details: lib32-lv2 1.18.0-1

Git Clone URL: https://aur.archlinux.org/lib32-lv2.git (read-only, click to copy)
Package Base: lib32-lv2
Description: Successor to the LADSPA audio plug-in standard
Upstream URL: http://lv2plug.in/
Licenses: custom, LGPL
Conflicts: lib32-lv2core
Provides: lib32-lv2core
Replaces: lib32-lv2core
Submitter: llde
Maintainer: llde
Last Packager: llde
Votes: 1
Popularity: 0.000001
First Submitted: 2017-08-24 21:23
Last Updated: 2020-05-11 21:21

Dependencies (7)

Required by (3)

Sources (1)

Latest Comments

1 2 Next › Last »

npfeiler commented on 2020-10-04 01:44

similar to the already existing touch __init__.py touch touch tools/__init__.py is a workaround

@rodrigo21 would also be nice for lib32-serd, lib32-sord, lib32-sratom and lib32-lilv

llde commented on 2020-05-18 12:27

@rodrigo21 I will try to check if a workaround exist

rodrigo21 commented on 2020-05-16 16:39

@DarkShadow44

Yes, I have Anki installed. You don't need to uninstall it, just build in a clean chroot.

DarkShadow44 commented on 2020-05-16 15:54

@rodrigo21

I was also getting the ImportError: cannot import name 'autowaf' from 'tools' (/usr/lib/python3.8/site-packages/tools/__init__.py)

Do you happen to have anki installed? Because anki adds a "tools" package in "/usr/lib/python3.8/site-packages/tools". That confuses waf and makes it load the wrong module, which obviously does not export "autowaf".

Not sure if we can fix anything here (not too deep into python), but removing anki lets it compile for me.

DDoSolitary commented on 2020-05-12 04:13

@llde Strangely, when I tried to build this package months ago waf complained about unable to find "gcc -m32" but now it works fine. I can build the new package without issues. Thanks for the update.

rodrigo21 commented on 2020-05-11 22:23

EDIT: It builds fine in a clean chroot. Thanks for the update.

I'm getting this error:

Waf: The wscript in '/home/rodrigo/Curioso/Packages/scratch/TK/lib32-lv2/src/lv2-1.18.0' is unreadable
Traceback (most recent call last):
File "/lib/python3.8/site-packages/waf/waflib/Scripting.py", line 141, in waf_entry_point
set_main_module(wscript)
File "/lib/python3.8/site-packages/waf/waflib/Scripting.py", line 191, in set_main_module
Context.g_module = Context.load_module(file_path)
File "/lib/python3.8/site-packages/waf/waflib/Context.py", line 682, in load_module
exec(compile(code, path, 'exec'), module.__dict__)
File "/home/rodrigo/Curioso/Packages/scratch/TK/lib32-lv2/src/lv2-1.18.0/wscript", line 8, in <module>
from tools import autowaf as autowaf
ImportError: cannot import name 'autowaf' from 'tools' (/usr/lib/python3.8/site-packages/tools/__init__.py)

llde commented on 2020-05-11 21:04

@DDoSolitary Hey sorry for the late answer. My email got flooded and missed the topic. Yes I accidentally uploaded the compiled package. As I'm in the process of updating to 1.18 I will remove it when I push.

However I can't reproduce at all your issues with CC and CXX envvars. They work and are recognized fine by waf. (Most other package that use waf are using these) I will hoowever check using CFLAGS after the next update. Is your gcc installed in a non standard directory that is not in PATH? When one of the commands fail the entire generation is halted. Regarding the headers I don't know why they are shipped inside the lib folder.

I will add lv2 depend and fix the python makedepend. Also adding waf depend.

DDoSolitary commented on 2020-02-17 04:02

This package is literally broken currently. The .so libraries are never build for the reason I described in a previous comment, so the only thing is provides now is the exactly same header files as those provided by the 64-bit lv2 package.

Here's my patch to fix this package: https://github.com/DDoSolitary/archlinux-repo/blob/master/lib32-lv2.patch

And this commit message describes the changes I made in the patch: https://github.com/DDoSolitary/archlinux-repo/commit/a0ecac4fb7cf4472cdd5fe3e1b370918bbfcebaa

DDoSolitary commented on 2020-02-16 15:52

It seems that you accidentally pushed the built package file to AUR: lib32-lv2-1.16.0-1-x86_64.pkg.tar.xz

tjackson commented on 2019-11-29 00:06

Thanks for updating. Can you add waf as a makedepend?