Package Details: lib32-gtk 1.2.10-2

Git Clone URL: https://aur.archlinux.org/lib32-gtk.git (read-only, click to copy)
Package Base: lib32-gtk
Description: A multi-platform toolkit (v1) (32-bit)
Upstream URL: http://www.gtk.org/
Licenses: LGPL
Submitter: prg
Maintainer: prg (salmonix)
Last Packager: prg
Votes: 14
Popularity: 0.052264
First Submitted: 2015-12-15 03:39
Last Updated: 2021-01-20 17:16

Latest Comments

prg commented on 2021-01-20 17:17

Adding salmonix as a co maintainer

I've updated the URL, but there are still issues with the build

I don't use this package anymore and don't have time to update it so feel free to fix it up

salmonix commented on 2021-01-20 17:12

Unable to build. curl: (7) Failed to connect to ftp.gnome.org port 21 while downloading gtk+-1.2.10.tar.gz

The url for gtk+1.2.10 is ftp://ftp.gnome.org/pub/gnome/sources/gtk+/1.2/gtk+-${pkgver}.tar.gz

Most likely it should be https://download.gnome.org/sources/gtk+/1.2/gtk+-${pkgver}.tar.gz

zwastik commented on 2016-04-04 16:14

Weird, I am still unable to build the package:

checking for extra flags to get ANSI library prototypes... none needed
checking for extra flags for POSIX compliance... none needed
checking for glib-config... /usr/bin/glib-config
checking for GLIB - version >= 1.2.8... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB was incorrectly installed
*** or that you have moved GLIB since it was installed. In the latter case, you
*** may want to edit the glib-config script: /usr/bin/glib-config
configure: error:
*** GLIB 1.2.8 or better is required. The latest version of GLIB
*** is always available from ftp://ftp.gtk.org/.
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build lib32-gtk.
==> Restart building lib32-gtk ? [y/N]

config.log: http://pastebin.com/rjDszC3D

prg commented on 2016-03-31 23:51

Hi zwastik,

Thanks for reporting the build issue. The reason for the build failure was because lib32-glib does not provide the "glib-config" binary that the lib32-gtk makefile requires. lib32-glib can't provide "glib-config" or else it would conflict with the normal "glib" AUR package. Because of this, I've added a makedepends to "glib" for this package.

I checked lib32-glib2 in [multilib] and that's more-or-less how it's handled there.

The latest update to the PKGBUILD should fix your issue. Let me know if you are still having problems. Thanks again.

zwastik commented on 2016-03-30 14:26

checking for glib-config... /usr/bin/glib-config
checking for GLIB - version >= 1.2.8... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB was incorrectly installed
*** or that you have moved GLIB since it was installed. In the latter case, you
*** may want to edit the glib-config script: /usr/bin/glib-config
configure: error:
*** GLIB 1.2.8 or better is required. The latest version of GLIB
*** is always available from ftp://ftp.gtk.org/.
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build lib32-gtk.
==> Restart building lib32-gtk ? [y/N]


The config.log file: http://pastebin.com/bkw9Gu0S