Package Details: lib32-gst-plugins-ugly 1.14.4-2

Git Clone URL: https://aur.archlinux.org/lib32-gst-plugins-ugly.git (read-only)
Package Base: lib32-gst-plugins-ugly
Description: GStreamer Multimedia Framework Ugly Plugins (32-bit)
Upstream URL: https://gstreamer.freedesktop.org/
Licenses: LGPL
Submitter: orumin
Maintainer: adam900710
Last Packager: adam900710
Votes: 14
Popularity: 0.164392
First Submitted: 2016-06-06 05:57
Last Updated: 2019-06-08 13:41

Latest Comments

1 2 Next › Last »

gverm commented on 2019-07-06 15:10

I would suggest to use the gitlab mirrors instead. They're fast and they solve the prepare() issue.

source=("git+https://gitlab.freedesktop.org/gstreamer/gst-plugins-ugly.git#commit=$_commit" "gst-common::git+https://gitlab.freedesktop.org/gstreamer/common.git")

kinodont commented on 2019-06-08 19:04

A failure occurred in prepare(): lib32-gst-plugins-ugly/PKGBUILD: line 33: cd: gst-plugins-ugly: No such file or directory

The repo has a different name (gstreamer-gst-plugins-ugly instead of just gst-plugins-ugly).

An alternate directory name needs to be added, like so:

source=("gst-plugins-ugly::git+https://github.com/freedesktop/gstreamer-gst-plugins-ugly.git#commit=$_commit")

adam900710 commented on 2018-08-18 01:09

For guys tired of the old upstream package, here is my PKGBUILDs for v1.14.2 lib32-gstreamer (needs new dependency from AUR): https://pastebin.com/baW8G4XV

And lib32-gst-plugins-base: https://pastebin.com/avFDFjB4

adam900710 commented on 2018-08-01 13:57

Please only mark this package out-of-date if extra/lib32-gst-plugins-base-libs get updated.

TemplarGR commented on 2018-07-01 09:35

Base and Good have been recently updated to 1.14.1 so this package needs to be updated as well now

singron commented on 2018-04-05 05:26

I think the failures happen because it's compiling with the headers from the gstreamer 1.14 x86_64 package, but linking against the lib32-gstreamer 1.12 32-bit libraries. Between 1.12 and 1.14, they changed the plugin ABI (specifically, they changed the name of the plugin entry symbol).

Unfortunately, the 32-bit package doesn't install the headers, so there isn't a simple fix. The 32-bit libraries in community need to be updated to 1.14 or the PKGBUILD needs to download its own gstreamer headers.

0e4ef622 commented on 2017-11-17 00:32

This package seems to be missing lib32-twolame from its dependencies list.

s4Ne commented on 2017-06-30 16:26

@zhenbo: Same here :/

zhenbo commented on 2017-03-20 07:48

Failed to build this package

PASS: generic/states
FAIL: elements/mpg123audiodec
FAIL: elements/amrnbenc
FAIL: elements/mpeg2dec
FAIL: elements/x264enc
FAIL: elements/xingmux
FAIL: pipelines/lame
============================================================================
Testsuite summary for GStreamer Ugly Plug-ins 1.8.3
============================================================================
# TOTAL: 7
# PASS: 1
# SKIP: 0
# XFAIL: 0
# FAIL: 6
# XPASS: 0
# ERROR: 0
============================================================================
See tests/check/test-suite.log
Please report to http://bugzilla.gnome.org/enter_bug.cgi?product=GStreamer
============================================================================

orumin commented on 2017-01-12 10:05

Now, version of Arch Linux's lib32-gst-plugins-base-libs package in multilib repository is still 1.8.3 .
I'll upgrade this package if lib32-gst-plugins-base-libs upgraded.