Package Details: lib32-gst-plugins-bad 1.16.2-6

Git Clone URL: https://aur.archlinux.org/lib32-gst-plugins-bad.git (read-only, click to copy)
Package Base: lib32-gst-plugins-bad
Description: GStreamer open-source multimedia framework bad plugins (32-bit)
Upstream URL: https://gstreamer.freedesktop.org/
Licenses: LGPL
Submitter: orumin
Maintainer: rodrigo21
Last Packager: rodrigo21
Votes: 13
Popularity: 0.000013
First Submitted: 2016-06-11 18:11
Last Updated: 2020-06-10 05:33

Dependencies (65)

Required by (0)

Sources (2)

Latest Comments

1 2 3 4 5 6 ... Next › Last »

Alkaris commented on 2020-08-16 15:25

How do you fix dependency for Neon?

Dependency neon found: NO found 0.31.2 but need: '<= 0.30.99' ; matched: '>= 0.27'

ERROR: Invalid version of dependency, need 'neon' ['<= 0.30.99'] found '0.31.2'

Why does this package require an older version when a newer version exists? is there way to tell it to use the new one instead of the old one? What needs to be edited in the PKGBUILD to do that?

hdnvjwhewqmcieuc commented on 2020-06-01 11:06

How am I supposed to deal with the tests libs_insertbin and elements_line21 failing? Is this happening because lib32-libkate has problems (server hosting it has been down for a month) and I tried the solutions in the comments?

JavanAsher commented on 2020-05-26 23:25

@rodrigo21 lib32-openexr rebuilt just fine. lib32-gst-plugins-bad shows the exact same error.

rodrigo21 commented on 2020-05-26 23:06

@JavanAsher, It seems to be a problem with lib32-openexr.

Try rebuilding lib32-openexr first and sees if it compiles.

JavanAsher commented on 2020-05-26 21:24

Package failed to build, if possible, would like some help. https://pastebin.com/Bautp2Gk

aaronp commented on 2020-05-12 17:12

If anyone else is running into a linker issue with gstlv2 stuff on gcc 10, adding -fcommon to CFLAGS worked.

EDIT:

Apparently you'd already cherry-picked the fixed this and I didn't notice. Sorry for the noise.

DDoSolitary commented on 2020-05-10 10:16

Broken because of the new vulkan-heanders package. The 64bit version in the official repo just added a patch to fix this: https://git.archlinux.org/svntogit/packages.git/tree/trunk/0001-vulkan-Drop-use-of-VK_RESULT_BEGIN_RANGE.patch?h=packages/gst-plugins-bad&id=511b4cb2a2d2c06fe42bab4f288e889ad0a0e7ae

Strunkenbold commented on 2020-05-09 19:22

Package built successfully today for me. Thx for fixing it.

programegg commented on 2020-05-07 15:51

Package fails to build for me.

Dependency neon found: NO found 0.31.1 but need: '<=0.30.99' ; matched '>=0.27'
Run-time depenedency neon found: NO (tried cmake)

gst-plugins-bad/ext/neon/meson.build:1:0: ERROR: Invalid version of dependency, need 'neon' ['<=0.30.99'] found '0.31.1'.

Strunkenbold commented on 2020-05-01 20:12

packages fails to build for me:

Run-time dependency librsvg-2.0 found: NO (tried cmake)

gst-plugins-bad/ext/rsvg/meson.build:7:0: ERROR: Could not generate cargs for librsvg-2.0: Package shared-mime-info was not found in the pkg-config search path. Perhaps you should add the directory containing `shared-mime-info.pc' to the PKG_CONFIG_PATH environment variable Package 'shared-mime-info', required by 'gdk-pixbuf-2.0', not found