Package Details: lib32-gst-plugins-bad 1.18.4-2

Git Clone URL: https://aur.archlinux.org/lib32-gst-plugins-bad.git (read-only, click to copy)
Package Base: lib32-gst-plugins-bad
Description: Multimedia graph framework - bad plugins (32-bit)
Upstream URL: https://gstreamer.freedesktop.org/
Licenses: LGPL
Submitter: orumin
Maintainer: rodrigo21
Last Packager: rodrigo21
Votes: 19
Popularity: 3.06
First Submitted: 2016-06-11 18:11
Last Updated: 2021-04-30 16:51

Dependencies (79)

Required by (0)

Sources (2)

Latest Comments

1 2 3 4 5 6 ... Next › Last »

rodrigo21 commented on 2021-05-11 18:12

@Samega7Cattac Try updating lib32-openexr.

Samega7Cattac commented on 2021-05-11 17:25

Missing include

/usr/include/OpenEXR/ImfHeader.h:22:10: fatal error: ImathVec.h: No such file or directory
   22 | #include "ImathVec.h"

ttd1 commented on 2021-04-08 16:26

@DDoSolitary, first of all, thanks for all the help, I eventually figured out that having my VPN turned on prevented some of the package dependencies from being downloaded. Afterwards, i couldn't finish building the lib32-libsrtp dependency, but finally, after doing what @allencch suggested in the lib32-libsrtp AUR page i was finally able to build the lib32-gst-plugins-bad without problems and as far as i can tell its working as expected now.

DDoSolitary commented on 2021-04-08 13:20

@ttd1 I just checked the packages you listed but all of them work fine.

ttd1 commented on 2021-04-08 13:15

The dependencies listed below seem to have their source broken/offline, so at the moment the package fails to build. By the looks of it Proton 6.3 requires this for some old x86 game video content to work (MPEG-1 decoder in my case) :S

Thanks in advance if someone is able to fix it.

Dependencies: lib32-lv2 lib32-raptor lib32-liblrdf lib32-gupnp-igd lib32-libnice lib32-libsrtp lib32-serd lib32-sord lib32-lilv lib32-sratom

https://pastebin.com/kvxKw4FY

rodrigo21 commented on 2020-11-26 07:20

I'm waiting for the repo packages to be updated. It's flagged out of date since September.

@DDoSolitary

When I update the package to 1.18 I will check again the dependencies. Thanks for the reports.

DDoSolitary commented on 2020-11-26 06:24

@Lakso This package is built against headers from the gstreamer package, which has been updated to v1.18, but the lib32-gstreamer and lib32-gst-plugins-* packages are still on v1.16. So the plugins built for newer gstreamer can't be loaded by the old lib32-gstreamer. You need to install an older version of gstreamer to build this package, for example https://archive.archlinux.org/packages/g/gstreamer/gstreamer-1.16.2-2-x86_64.pkg.tar.zst

DDoSolitary commented on 2020-11-26 06:09

May I know why you disabled the dtls plugin? I can build it without issues.

DDoSolitary commented on 2020-11-26 05:26

According to the official gst-plugins-bad package, lib32-libmpeg2 is not needed and lib32-bluez-libs should be in makedepends. I've checked the built package and didn't find any dependency on their so library files.

Lakso commented on 2020-09-29 15:27

  ==> ERROR: A failure occurred in check().
    Aborting...
error making: lib32-gst-plugins-bad  

here's the logfile if it's useful