Package Details: lib32-gd 2.3.2-1

Git Clone URL: https://aur.archlinux.org/lib32-gd.git (read-only, click to copy)
Package Base: lib32-gd
Description: Library for the dynamic creation of images by programmers (32-bit)
Upstream URL: https://libgd.github.io/
Licenses: custom
Submitter: orumin
Maintainer: rodrigo21
Last Packager: rodrigo21
Votes: 5
Popularity: 0.53
First Submitted: 2017-07-08 20:18
Last Updated: 2021-04-01 03:18

Latest Comments

« First ‹ Previous 1 2

rodrigo21 commented on 2020-12-07 05:20

@ben_sa2000

Check the wiki: https://wiki.archlinux.org/index.php/DeveloperWiki:Building_in_a_clean_chroot

You can use multilib-build. You have to build lib32-libxpm from the AUR first and pass it to the chroot. I run like this: multilib-build -r <DIRECTORY OF THE CHROOT> -- -I <PATH TO lib32-libxpm-3.5.13-2-x86_64.pkg.tar.zst>

You can also use clean-chroot-manager.

ben_sa2000 commented on 2020-12-07 04:04

@rodrigo21 How to build lib32-gd in a clean chroot

brianmsm commented on 2020-12-01 22:43

@sl1pkn07 you're right! Installing lib32-libraqm solve the issue.

danievdm commented on 2020-12-01 17:23

Seems quite a few are getting a similar error:

/usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-pc-linux-gnu/10.2.0/../../../libraqm.so when searching for -lraqm
/usr/bin/ld: skipping incompatible /usr/lib/libraqm.so when searching for -lraqm
/usr/bin/ld: cannot find -lraqm

sl1pkn07 commented on 2020-11-30 00:06

missing lib32-libraqm

rodrigo21 commented on 2020-11-29 20:33

@brianmsm

Building fine here. Try building in a clean chroot.

brianmsm commented on 2020-11-29 17:39

I get this error:

/usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-pc-linux-gnu/10.2.0/../../../libraqm.so when searching for -lraqm
/usr/bin/ld: skipping incompatible /usr/lib/libraqm.so when searching for -lraqm
/usr/bin/ld: cannot find -lraqm
/usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-pc-linux-gnu/10.2.0/../../../libraqm.so when searching for -lraqm
/usr/bin/ld: skipping incompatible /usr/lib/libraqm.so when searching for -lraqm
collect2: error: ld returned 1 exit status
make[2]: *** [Makefile:685: libgd.la] Error 1
make[2]: Leaving directory '/home/brian/.cache/yay/lib32-gd/src/libgd-2.3.0/src'
make[1]: *** [Makefile:600: all] Error 2
make[1]: Leaving directory '/home/brian/.cache/yay/lib32-gd/src/libgd-2.3.0/src'
make: *** [Makefile:417: all-recursive] Error 1
==> ERROR: A failure occurred in build().
    Aborting...
error making: lib32-gd

sl1pkn07 commented on 2017-07-09 09:08

please add lib32-libtiff to depends

lib32-gd E: Dependency lib32-libtiff detected and not included (libraries ['usr/lib32/libtiff.so.5'] needed in files ['usr/lib32/libgd.so.3.0.4'])

from namcap

greetings