Package Details: lib32-faudio-git 19.08.r0.g2cc0ee5-3

Git Clone URL: https://aur.archlinux.org/lib32-faudio-git.git (read-only)
Package Base: lib32-faudio-git
Description: XAudio2 reimplementation
Upstream URL: https://github.com/FNA-XNA/FAudio/
Licenses: custom:zlib
Conflicts: lib32-faudio
Provides: lib32-faudio
Submitter: flatwhatson
Maintainer: flatwhatson
Last Packager: flatwhatson
Votes: 3
Popularity: 0.123957
First Submitted: 2018-11-07 13:08
Last Updated: 2019-08-02 05:08

Required by (2)

Sources (2)

Latest Comments

silly commented on 2019-08-02 17:32

@flatwhatson no problemo, thanks for the quick update.

flatwhatson commented on 2019-08-02 05:05

@silly Thanks for letting me know!

You're right, the patch is no longer required.

Cheers!

silly commented on 2019-08-02 04:33

patch is not applying anymore. EDIT: Why is it even needed btw? Built for me without the patch.

patching file CMakeLists.txt
Hunk #1 FAILED at 154.
1 out of 1 hunk FAILED -- saving rejects to file CMakeLists.txt.rej
==> ERROR: A failure occurred in prepare().

flatwhatson commented on 2019-05-09 14:08

Updated to fix the SDL2 patch.

Updated to bring this package in-line with the community package:

  • using the proper tagged version
  • headers installed to /usr/include instead of /usr/include/FAudio

Make sure you install the latest faudio-git also!

flatwhatson commented on 2019-05-09 01:09

@PedroHLC Thanks for the heads-up, I'll get to this in a few hours.

PedroHLC commented on 2019-05-08 20:02

patch is not applying:

==> Starting build()...
patching file CMakeLists.txt
Hunk #1 FAILED at 135.
1 out of 1 hunk FAILED -- saving rejects to file CMakeLists.txt.rej
==> ERROR: A failure occurred in build().

flatwhatson commented on 2019-01-25 13:09

@Nocifer thanks for the heads-up, I've pushed a fix.

Nocifer commented on 2019-01-25 11:41

Tried to build the latest git and failed, seems like force-lib32-sdl2.patch needs to be tweaked a bit. endif(FFMPEG) is now on line 135 instead of line 133 and find_package(SDL2 CONFIG REQUIRED) has become find_package(SDL2 CONFIG).

diff --git a/CMakeLists.txt b/CMakeLists.txt
index 588c72a..21191a2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -135,7 +135,7 @@ if(FFMPEG)
 endif(FFMPEG)

 # SDL2 Dependency
-find_package(SDL2 CONFIG)
+include(/usr/lib32/cmake/SDL2/SDL2Config.cmake)
 if (TARGET SDL2::SDL2)
    message(STATUS "using TARGET SDL2::SDL2")
    target_link_libraries(FAudio PUBLIC SDL2::SDL2)

flatwhatson commented on 2018-12-09 14:45

@Enverex The lib32 build was a bit tricky! All updated now, cheers.

Enverex commented on 2018-12-09 13:24

Looks like they've done the CMake refactor. You've updated the 64bit script but not this one yet. Can you update this one as well please?