Package Details: leo 6.2.1-1

Git Clone URL: https://aur.archlinux.org/leo.git (read-only, click to copy)
Package Base: leo
Description: Outliner, Editor, and Personal Information Manager written in 100% Python
Upstream URL: http://leoeditor.com
Keywords: sqlite3
Licenses: BSD, MIT
Submitter: None
Maintainer: ragouel
Last Packager: ragouel
Votes: 28
Popularity: 0.000003
First Submitted: 2006-05-08 11:34
Last Updated: 2020-05-13 05:40

Latest Comments

1 2 3 Next › Last »

birnenwerfer commented on 2020-03-07 15:48

@JDWUP I tried to build it the same way but seems like it doesn't work on my machine. I use the latest stable version of manjaro, but am also not an expert of PKGBUILD. Anyone here knows who maintained the package before? Or anyone who can give me a hint how to learn PKGBUILD and becoming a Maintainer?

JDWUP commented on 2020-02-29 06:31

@birnenwerfer Hi, I am very new to PKGBUILD but I tried to modify the file. I am able to successfully build the package. This (https://gist.github.com/JohnWang1023/732d23904f51873effd610e1b3391f44) is what I changed.

birnenwerfer commented on 2020-02-24 15:53

Hi guys, seems like it doesn't work anymore and there is no maintainer. I really would like to maintain it, but I don't know how. Maybe someone who can give me a hint to some tutorials or descriptions how to maintain the packagebuild and dependencies etc ...? Thanks in adavance!

zielhno commented on 2018-09-05 12:55

PKGBUILD needs some updates:

  1. The packaging path and directory after untaring do not match (leo-5.3.7 vs. leo-editor-5.3.7)

  2. LICENSE.TXT became just LICENSE

There are still other issues, but I think these two issues need to be fixed for sure.

djscholl commented on 2015-10-26 19:26

Arch version bump for dependencies; thanks to Arch user SideburnEtic.

SideburnEtic commented on 2015-10-18 06:18

Please add pip's setuptools as dependency. Also, Qt 4.8.7 is the last planned patch release in the Qt4 series with standard support ending in December 2015, after which The Qt Company's paid support will only be available. The Qt Company is encouraging all Qt 4 users to upgrade to Qt 5.

djscholl commented on 2014-12-21 01:13

Version 5.0 from upstream; also updated PKGBUILD from python 2 to 3.

exaos commented on 2014-12-15 13:04

Leo 5.0 is ready.

djscholl commented on 2013-11-09 05:38

New minor version from upstream.

djscholl commented on 2013-04-21 14:18

Arch version bump to update project home page (thanks to Arch user contrebasse) and modernize PKGBUILD.