Package Details: lensfun-git 0.3.2.r2032.gad957f64-1

Git Clone URL: https://aur.archlinux.org/lensfun-git.git (read-only, click to copy)
Package Base: lensfun-git
Description: Database of photographic lenses and a library that allows advanced access to the database
Upstream URL: https://lensfun.github.io/
Licenses: LGPL3
Conflicts: lensfun
Provides: lensfun=0.3.0
Submitter: None
Maintainer: hcartiaux
Last Packager: hcartiaux
Votes: 11
Popularity: 0.000001
First Submitted: 2014-06-13 16:23
Last Updated: 2021-02-11 12:34

Required by (25)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

hcartiaux commented on 2016-01-13 09:41

Should be fixed...

soupault commented on 2016-01-13 09:11

==> Entering fakeroot environment...
==> Starting package()...
[ 93%] Built target lensfun
[100%] Built target python-package
Install the project...
-- Install configuration: "Release"
CMake Error at cmake_install.cmake:36 (file):
file cannot create directory: /usr/local/include/lensfun. Maybe need
administrative privileges.


Makefile:137: recipe for target 'install' failed
make: *** [install] Error 1
==> ERROR: A failure occurred in package().
Aborting...
==> ERROR: Makepkg was unable to build lensfun-git.

Anonymous comment on 2014-12-22 01:09

updated

nanomad commented on 2014-12-21 15:30

Hi,

I've fixed the provides so that it doesn't break darktable dependencies.

Here's the updated version: http://lpaste.net/116964

Anonymous comment on 2014-10-22 11:08

updated

Anonymous comment on 2014-10-21 19:15

For me, the build fails with:
==> Starting build()...
/home/matej/makepkg/lensfun-git/PKGBUILD: line 24: ./configure: No such file or directory

Anonymous comment on 2014-06-13 16:23

moved to sf.net

Nordlicht commented on 2013-11-23 21:30

Changing the configure script:

# Check for tools
-tibs.check_program ("GNU Make", "make --version", ".*?([0-9\.]+).*", "3.81", True)
+tibs.check_program ("GNU Make", "make --version", ".*?([0-9\.]+).*", "4.0-1", True)

makes it work again.

Nordlicht commented on 2013-11-23 19:52

This does not work.

Errormessage:

"Checking for GNU Make >= 3.81 ...4.0 < 3.81, FAILED

GNU Make version 3.81 and above is required to build this project
"

gobostone commented on 2013-09-27 17:50

I forgot to include a link. Currently the most recent revision is revision 263. This was found here:

http://svn.berlios.de/wsvn/lensfun/trunk/?#a0b40758157c8f16fa703ca3be466fa8a