Package Details: ledger-live 2.31.1-1

Git Clone URL: https://aur.archlinux.org/ledger-live.git (read-only, click to copy)
Package Base: ledger-live
Description: Ledger Live - Desktop
Upstream URL: https://github.com/LedgerHQ/ledger-live-desktop
Keywords: bitcoin cryptocurrency wallet
Licenses: MIT
Conflicts: ledger-live-bin, ledger-live-git
Provides: ledger-live
Submitter: meriadec
Maintainer: phnx47
Last Packager: phnx47
Votes: 14
Popularity: 1.35
First Submitted: 2018-07-19 09:01
Last Updated: 2021-07-30 13:57

Latest Comments

1 2 3 4 5 Next › Last »

phnx47 commented on 2021-06-17 12:57

@crabvk Yes, sorry, my mistake... LedgerHQ should fix that

crabvk commented on 2021-06-17 12:38

@phnx47
You're not building in clean chroot, right?
Also, as a maintainer, you have .git repo within PKGBUILD which makes the git call succeed.

phnx47 commented on 2021-06-17 12:28

@crabvk Btw, I don't have problems with compiling this package. Everything correct in PKGBUILD, command git rev-parse --short HEAD not used during the build

crabvk commented on 2021-06-17 11:46

@phnx47
Ok, fair enough. But this line causes the error https://github.com/LedgerHQ/ledger-live-desktop/blob/develop/tools/main.js#L15, because there's no git repo if building in clean chroot.

created an issue

phnx47 commented on 2021-06-17 11:26

@crabvk It is not git version. Git used for npm packages only.

crabvk commented on 2021-06-17 11:20

Hi. I've got an error

Error: Command failed: git rev-parse --short HEAD
fatal: not a git repository (or any of the parent directories): .git

That's because the archive from the source= has no .git. I think you should change it to "git+https://github.com/LedgerHQ/ledger-live-desktop.git#tag=v${pkgver}".
Here's the patch https://gist.github.com/crabvk/0da29fa5fc6e8312282b38fe5fc545ae

phnx47 commented on 2021-06-12 05:39

@dr460nf1r3 yes, yarn needs git for install packages

dr460nf1r3 commented on 2021-06-11 15:03

I assumed it was needed because without I got an error message about it missing. The log is also from a clean chroot btw.

phnx47 commented on 2021-06-11 14:21

@dr460nf1r3 It is shouldn't use git. Log looking strange. I will check it in clean system

dr460nf1r3 commented on 2021-06-11 12:11

Please add git to makedepends, needed in clean chroot. Also please have a look at this log, can't get this package to compile :/