Package Details: lcdnurse 1.0.3-3

Git Clone URL: https://aur.archlinux.org/lcdnurse.git (read-only)
Package Base: lcdnurse
Description: Heal dead pixels on your LCD screen thanks to the blink method
Upstream URL: http://congelli.eu/prog_info_lcdnurse.html
Licenses: GPL
Submitter: danyf90
Maintainer: None
Last Packager: jyantis
Votes: 8
Popularity: 0.121828
First Submitted: 2013-11-06 17:53
Last Updated: 2015-06-11 16:00

Latest Comments

mxfm commented on 2019-06-07 19:35

Currently I can compile this package, but not in clean chroot. It seems it needs 'libxxf86vm' as makedepends.

/usr/bin/ld: warning: libXxf86vm.so.1, needed by /usr/lib/gcc/x86_64-pc-linux-gnu/8.3.0/../../../../lib/libwx_gtk2u_core-2.8.so, not found (try using -rpath or -rpath-link)

/usr/bin/ld: /usr/lib/gcc/x86_64-pc-linux-gnu/8.3.0/../../../../lib/libwx_gtk2u_core-2.8.so: undefined reference to `XF86VidModeSwitchToMode'

/usr/bin/ld: /usr/lib/gcc/x86_64-pc-linux-gnu/8.3.0/../../../../lib/libwx_gtk2u_core-2.8.so: undefined reference to `XF86VidModeGetModeLine'

/usr/bin/ld: /usr/lib/gcc/x86_64-pc-linux-gnu/8.3.0/../../../../lib/libwx_gtk2u_core-2.8.so: undefined reference to `XF86VidModeGetAllModeLines'

collect2: error: ld returned 1 exit status make[3]: *** [Makefile:398: lcdnurse] Error 1

mxfm commented on 2017-10-31 06:21

I used the package successfully a year ago. Yesterday I compiled it again, but the application does not launch as expected. The screen goes dark without dialog box, if I switch with alt-tab to another window, I still stay at lcdnurse window, but now can see the color chooser dialog box. However, if I press OK button, lcdnurse window disappears and the moitor stays dark. Pressing at any window space causes nothing. Because this blocks access to other windows, the solution is to kill the app in another terminal.

I suspect this is caused by incompatibility with window manager. I use lxdm 0.5.3-4 with openbox 3.6.1-3.

jyantis commented on 2015-03-20 11:14

I noticed this was orphaned so I took it over and added the below fix.

jyantis commented on 2015-03-19 04:37

Turns out that if you try to get the file from the main site without a browser based user agent it will not download correctly.

This is the main sites file:
http://en.congelli.eu/download/lcdnurse/lcdnurse-1.0.3.tar.gz

I believe the maintainer worked around this by hosting it on dropbox. The problem is that the one he currently has on dropbox now is a not valid file.

You can just change the source to this line (leave the checksums the same). And you should be good to go.
source=("http://yantis-scripts.s3.amazonaws.com/lcdnurse-1.0.3.tar.gz")

jyantis commented on 2015-03-19 04:36

Turns out that if you try to get the file from the main site without a browser based user agent it will not download correctly.

This is the main sites file:
http://en.congelli.eu/download/lcdnurse/lcdnurse-1.0.3.tar.gz

I believe the maintainer worked around this by hosting it on dropbox. The problem is the one he currently has on dropbox now is a none valid file.

You can just change the source to this line (leave the checksums the same). And you should be good to go.
source=("http://yantis-scripts.s3.amazonaws.com/lcdnurse-1.0.3.tar.gz")

korgan1983 commented on 2015-03-03 16:22

Hi, package doesn't work anymore:

==> Validating source files with sha512sums...
lcdnurse-1.0.3.tar.gz ... FAILED
==> ERROR: One or more files did not pass the validity check!


If I update checksum (updpkgsums) or ignoring it (--skipchecksums) it still breaks:

==> Starting build()...
/home/exchange/lcdnurse/PKGBUILD: line 15: cd: /home/exchange/lcdnurse/src/lcdnurse-1.0.3: No such file or directory
==> ERROR: A failure occurred in build().
Aborting...

I think the package is broken, got different checksums

steelAxis commented on 2014-02-25 13:22

Yeah to successfully build it, I had to add “--with-wx-config=/usr/bin/wx-config-2.8“ to the ./configure line in PKGBUILD.
I have both wxgtk (3.0) and wgtk2.8 installed, it looks like it doesn't build with the default wxgtk (3.0).

hansi commented on 2013-11-29 00:37

Doesn't build anymore :-/

danyf90 commented on 2013-11-07 07:40

thanks for the feedback i've uploaded an updated version of the package

sekret commented on 2013-11-06 19:26

The download doesn't work. Trying to download it via browser showed me, that cookies have to be allowed. That really sucks!!

danyf90, your checksum is wrong because of the described problem.

md5sums=('9507ea6c86ca8b0ba0e2baf8e5c1dcf3')

is correct.

Furthermore, you need to add

depends=('wxgtk')

But then trying to launch it, it segfaults *sigh*