Package Details: lastfm 2.1.36-2

Git Clone URL: https://aur.archlinux.org/lastfm.git (read-only)
Package Base: lastfm
Description: The official Last.fm desktop application suite
Upstream URL: http://www.last.fm/
Licenses: GPL3
Conflicts: lastfm-git, lastfm-mpd-cli, lastfm-msk, lastfm-msk-light
Provides: lastfm
Submitter: fzerorubigd
Maintainer: ValHue
Last Packager: ValHue
Votes: 24
Popularity: 0.000071
First Submitted: 2013-02-09 08:42
Last Updated: 2018-01-01 11:59

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

Nattgew commented on 2013-10-09 00:55

I believe libavformat is provided by the ffmpeg package:
https://www.archlinux.org/packages/extra/i686/ffmpeg/files/

ifschleife commented on 2013-10-08 07:24

On a newly set up Archlinux system I can't even get so far as to add the patch by dront78.
Build fails with "Project ERROR: Package libavformat not found"
What package exactly does it want?

dront78 commented on 2013-09-22 14:28

compile could be fixed by patching
app/client/Fingerprinter/LAV_Source.cpp

replacing
AVCODEC_MAX_AUDIO_FRAME_SIZE
to
192000

source
http://www.mail-archive.com/arch-commits@archlinux.org/msg141328.html

Anonymous comment on 2013-09-01 19:08

Build fails (version 2.1.30-3)
http://pastebay.com/1290848

gourdcaptain commented on 2013-08-01 18:43

After updates today to ffmpeg-compat, this program crashes with the error:
bin/Last.fm Scrobbler: error while loading shared libraries: libavformat.so.54: cannot open shared object file: No such file or directory

It also won't build properly, resulting in the error:
Fingerprinter/LAV_Source.cpp:86:23: error: ‘AVCODEC_MAX_AUDIO_FRAME_SIZE’ was not declared in this scope
uint8_t outBuffer[AVCODEC_MAX_AUDIO_FRAME_SIZE*4];
^
Fingerprinter/LAV_Source.cpp:87:22: error: ‘AVCODEC_MAX_AUDIO_FRAME_SIZE’ was not declared in this scope
uint8_t overflow[AVCODEC_MAX_AUDIO_FRAME_SIZE*4];
^
Fingerprinter/LAV_Source.cpp: In member function ‘uint8_t* LAV_SourcePrivate::decodeOneFrame(int&, int&, int&)’:
Fingerprinter/LAV_Source.cpp:181:35: error: ‘outBuffer’ was not declared in this scope
uint8_t *pOutBuffer = outBuffer;
^
Fingerprinter/LAV_Source.cpp:275:12: error: ‘outBuffer’ was not declared in this scope
return outBuffer;
^
Fingerprinter/LAV_Source.cpp: In member function ‘virtual int LAV_Source::updateBuffer(short int*, size_t)’:
Fingerprinter/LAV_Source.cpp:478:29: error: ‘class LAV_SourcePrivate’ has no member named ‘overflow’
memcpy( pBuffer, d->overflow, d->overflowSize );
^
Fingerprinter/LAV_Source.cpp:499:24: error: ‘class LAV_SourcePrivate’ has no member named ‘overflow’
memcpy( d->overflow, out + bytesToBuffer, d->overflowSize);
^
make[1]: *** [_build/LAV_Source.o] Error 1

lz3060 commented on 2013-06-03 12:46

qtwebkit is another dependency.

Anonymous comment on 2013-05-08 13:15

I'm not sure if this happens with any other desktop environment but on Mate this package has to be manually added to the menu. - /usr/bin/lastfm-scrobbler

skogler commented on 2013-03-25 10:26

To make it work for people with both qt4 and qt installed,
change the line where it says

"qmake -r"
to
"qmake-qt4 -r"

skogler commented on 2013-03-25 10:25

To make it work for people with both qt4 and qt installed,
change the line where it says

"qmake -r" ...something
to
"qmake-qt4 -r" ...something

Anonymous comment on 2013-03-22 09:02

I'm getting the following error:

compiling MainWindow.cpp
MainWindow.cpp:33:20: fatal error: QWebView: No such file or directory
compilation terminated.
make[1]: *** [_build/MainWindow.o] Error 1
make[1]: Leaving directory `/tmp/yaourt-tmp-andy/aur-lastfm/src/lastfm-desktop-2.1.30/app/client'
make: *** [sub-app-client-make_default-ordered] Error 2